[pulseaudio-discuss] Unable to contact D-Bus (without a $DISPLAY for X11)

Jan pulseaudio at microfx.de
Tue May 21 10:17:01 UTC 2019


I am running patchbox OS for raspberry pi (raspbian stretch). My goal is to pipe regular alsa apps to jack and have a loopback. Since I failed with alsa I wanted to try pulseaudio since I read there are plugins/modules for jack already included. 

But as it turns out I am not even able to start pulseaudio. Feeling dumb. Tried a lot of tipps from all over the web but this is above my abilities.

When I start my pulseaudio service I get this: 

pulseaudio[1222]: W: [pulseaudio] server-lookup.c: Unable to contact D-Bus: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11  

I have tried to add 

DBUS_SESSION_BUS_PID=`cat /run/dbus/pid`

to /etc/rc.local ..but it didn’t change a thing. Yes, I have absolutely no idea what I am doing. I just know I have wasted countless hours already in my life with this DBus (had a similar problem with jack audio once and gave up until I found this patchbox distro which had it ready already). So at least I know that dbus is already working on this system.

Any ideas? 


More information about the pulseaudio-discuss mailing list