[pulseaudio-discuss] max deviation is never above 50%

Mike Fisher mike at fisher5.com
Fri Oct 2 05:10:20 UTC 2020

Fresh reboot.
I ran these 4 commands simultaneously:
arecord -f cd ALSAoutput.wav
parecord PAoutput.wav
All volumes to 100%
Started them all recording at the same time, and here are my results.
arecord -f cd ALSAoutput.wav Full deflection
parecord PAoutput.wav Full deflection
gnome-sound-recorder 50% deflection
audacity Full deflection
I did not use  pasuspender for any test.

It used to be the case that if I had pulse running it would grab ALSA, and
no other applications could use ALSA directly. They had to use pulse which
allows more than one application to use sound at the same time. I would
open Audacity using the pulse host. Then I would only get 50% max

I don't know what changed, but this is actually the first time I have ever
gotten audacity to get full deviation without having to
auto spawn=no; pulseaudio -k
Then launch Audacity to grab ALSA which causes other apps to be blocked.

So this is a good start. Audacity now only sees ALSA as host, and pulse is
no longer available as a host. This is confusing me as this never happened
before while pulse was still running. I know pulse is running because
pavucontrol still shows all its controls.

So I reboot and repeat the test to find out that I get the same result a/s
above. Audacity has full deviation with pulse running (Audacity only sees
ALSA, but works nonetheless). So what am I bitching about, it seems to be
working. I should be happy and just go away without understanding WHY this
is working. except for 1 item.

gnome-sound-recorder only gets 50% max deviation AT THE SAME TIME as 3
other applications are getting 100% ma deviation. WHAT????

So I have 4 sound clips recorded by 4 different apps all using pulse audio
3 of them get 100% max deviation and one does not.

[image: image.png]

Here is a fresh system config from right after the above test.

Man I hope someone can help me finger this all out.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20201001/256c6674/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image.png
Type: image/png
Size: 153263 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/pulseaudio-discuss/attachments/20201001/256c6674/attachment-0001.png>

More information about the pulseaudio-discuss mailing list