[pulseaudio-discuss] No audio output; same setup worked before

Rich Shepard rshepard at appl-ecosys.com
Sat Feb 13 21:25:22 UTC 2021

On Sat, 13 Feb 2021, Sean Greenslade wrote:

> Not sure what "papac" is. Do you mean "pacat"?


> Are you referring to the Kodi project's PAPlayer, or did you use "paplay"?
> What happens if you try paplay? What are the error messages you get, if
> any?

No, 'paplay':
$ paplay test-recording.flac 
Failed to open audio file.

$ pacat -p test-recording.flac

no sound.

> Also, can you open the generated .flac file with an audio editor to see
> if the audio actually got recorded in the first place?

Ah, nope. Audacity can't find content and 'ffprobe' returns,
$ ffprobe -hide_banner test-recording.flac 
[flac @ 0xc60d60] Format flac detected only with low score of 1, misdetection possible!
[flac @ 0xc60d60] Could not find codec parameters for stream 0 (Audio: flac, 0 channels): unspecified sample format
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, flac, from 'test-recording.flac':
   Duration: N/A, bitrate: N/A
     Stream #0:0: Audio: flac, 0 channels

On a different file (created yesterday):
$ ffprobe -hide_banner test-mic.wav 
Input #0, wav, from 'test-mic.wav':
   Duration: 00:00:16.00, bitrate: 64 kb/s
     Stream #0:0: Audio: pcm_u8 ([1][0][0][0] / 0x0001), 8000 Hz, 1 channels, u8, 64 kb/
$ pacat -p test-mic.wav
produced two clicks from the speaker.

Found one potential issue: the Focusrite had the 'Air' button pressed under
the input volumn knob. Turned that off. Now when I speak into the mic the
green ring light around the volumn knob fluctuates as does the pavucontrol
VU meter. But, still no output from the speakers.

The file size is 4727960 bytes so it does have content.


More information about the pulseaudio-discuss mailing list