[SCIM] Re: How to input Traditional Chinese with Scim

Kitae neeum at yahoo.com
Mon Oct 11 10:48:48 PDT 2004

On Mon, 2004-10-11 at 18:18 +0200, Rodolfo Medina wrote: 
> Dear Sir,
> excuse me if I'm writing you privately:
> I sent the present message to both scim-user and scim mailing list
> but got no reply up to now.

Oh, I also a member scim mailing list, but I didn't receive your mail.
and I can't find from http://freedesktop.org/pipermail/scim/2004-

> Maybe you could be so kind as to give me some help 
> or indicate some suitable place where to ask for help?

I will as I can, but I don't know chinese even if now live in china. But
I will reply this mail to scim mailing list, so if I wrong, may other
correct them and add more info. In scim mailing list, there  many so
kind members :-).

> I'm brand new to Scim.
> I've just installed it in order to input chinese characters,
> but don't know how to input Traditional Chinese.
> In fact, in the Smart Pinyin menu (in the toolbar right below)
> only Simplified Chinese appears.
> How can I input both Simplified and Traditional Chinese?
> Could you maybe give an example of a word or phrase input
> in Simplified and in Traditional Chinese?
> The installation of Scim turned out to be quite laborious
> because some problem arose. Maybe I don't manage to input Traditional
> Chinese
> because there were some errors and/or lacks in the installation?
> Below I'm reporting the various steps I followed.
> On my PC I have Mandrake Linux 9.1, and I use KDE as Desktop enviroment.
> Thanks, and excuse again,
> 				Rodolfo
> 1)  From
>     http://www.freedesktop.org/Software/ScimDownload
>     I downloaded scim-1.0.1.tar.gz and scim-chinese-0.4.2.tar.gz

scim-chinese, have a simplified Chinese input method that is smart
If you want to use traditional Chinese or other simplified input method,
you should install "scim-table", that have 12 input method for
traditional and simplified Chinese. 

http://scim.freedesktop.org/Software/ScimSupportLanguage show which
input method supported by which packages.

I only now smart pinyin usage. that 
In pinyin, you type nihaoma, show “你好吗"
I don't know others for how to useing.
> 2)  I unpacked scim-1.0.1.tar.gz and then I did:
>          # ./configure

You said you are use Mandrake linux. why don't use rpm?
I don't know Mandrake, so I am not sure, where I had to go for
Mandrake's rpm version, but I thin there is mandrake rpm package for
I think they have, and you can down load from

>     , but something went wrong, because at the end of the long output there
> was:
>          configure: error:
>          *** SCIM requires
>          ***      sizeof (unsigned short int)  == 2
>          ***      sizeof (char)                == 1
>          *** You might want to consider using the GNU C compiler.

I am not sure, but it's seem to be some kind GCC problem, what is your
PC CPU and gcc version. I think there is need more infor for solve the
or got advice. 

>     In fact, when I said '# make', I got:
>     [root at localhost scim-1.0.1]# make
>     make: *** No targets specified and no makefile found.  Stop.

./configure make Makefile, so if there is error during doing ./configure
You can't do make.

> 3)  'glibc' was already installed; then I also installed 'glibc-i18n';
>     but when I did './configure' to configure the package
> 'scim-1.0.1.tar.gz'
>     it still gave the error message
>         configure: error:
>         *** SCIM requires
>         ***      sizeof (unsigned short int)  == 2
>         ***      sizeof (char)                == 1
>         *** You might want to consider using the GNU C compiler.
> 4)  I did `$ drakconf' and installed all packages in the "Development Tool"
> catalog,
>     and finally I could install the `scim-1.0.1.tar.gz' package
>     with the ./configure, make and `make install' circle.

I just guess , before install drakconf, there is no some basic pakage
for compile in you linux box.

>     Everything seemed to go well, but when I tried to do the same with the
> package
>     scim-chinese-0.4.2.tar.gz I had problems with the ./configure:
>     in fact, it ended with the following message:
>     checking for scim >= 0.99.8... Package scim was not found in the
> pkg-config search path.
>     Perhaps you should add the directory containing `scim.pc'
>     to the PKG_CONFIG_PATH environment variable
>     No package 'scim' found
>     configure: error: Library requirements (scim >= 0.99.8) not met;
>     consider adjusting the PKG_CONFIG_PATH environment variable
>     if your libraries are in a nonstandard prefix so pkg-config can find
> them.

I think you /etc/ld.so.conf doesn't have /usr/local/lib
or if that have, do ldconfig may remove that error.

> 5)  I made sure the file 'scim.pc' was in /usr/local/lib/pkgconfig/,
>     then I said '$ export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig'
>     and then I builded scim-chinese-0.4.2.tar.gz, successfully, it seems.

> 6)  In the home directory I did:
>         # localedef -f GBK -i zh_CN zh_CN.gbk
> 7)  I ran '$ locale -a' to check if 'zh_CN.gbk' had been created.

You use UTF-8 locale, I think 6, and 7) aren't need for using scim with

> 8)  The file ~/.i18n did not exist, I created it and edited it as follows:
>         LANGUAGE=it_IT.UTF-8
>         XIM_PROGRAM=scim
>         LC_MEASUREMENT=it_IT.UTF-8
>         LC_TIME=it_IT.UTF-8
>         XIM=SCIM
>         LC_PAPER=it_IT.UTF-8
>         LC_TELEPHONE=it_IT.UTF-8
>         LC_MONETARY=it_IT.UTF-8
>         LC_NUMERIC=it_IT.UTF-8
>         LC_ADDRESS=it_IT.UTF-8
>         LC_NAME=it_IT.UTF-8
>         LC_MESSAGES=it_IT.UTF-8
>         ENC=it
>         LANG=it_IT.UTF-8
>         XMODIFIERS="@im=SCIM"
>         LC_CTYPE=it_IT.UTF-8
>         LC_COLLATE=it_IT.UTF-8

I think LC_XXX setting isn't need if not you want to change some, but I
think you don't need

make LC_XXXX to all it_IT.UTF-8
so that not need.
Just set if you want to change.

and for gtk program you should set 


> 9)  In the home directory, I did:
>         $ sh ~/.i18n
> 10) I did
>         # emacs /usr/local/etc/scim/global
>     , and replaced the line
>         /SupportedUnicodeLocales = en_US.UTF-8
>     with
>         /SupportedUnicodeLocales = en_US.UTF-8,it_IT.UTF-8
> 11) I did
>         # emacs /etc/X11/xinit/xinitrc
>     , and added the lines:
>         LC_CTYPE=zh_CN.gbk scim -d

Not need LC_CTYPE=zh_CN..gbk, just need is "scim -d"

>         export XMODIFIERS=@im=SCIM
> 12) I added the following lines to my .bash_profile file:
>         export LANG=it_IT.utf8

>         export LC_CTYPE=zh_CN.gbk

This isn't need for SCIM in your setting. 

> 13) In the file /etc/gtk-2.0/gtk.immodules I changed
>         "/usr/lib/gtk-2.0/2.2.0/immodules/im-xim.so"
>         "xim" "X Input Method" "gtk+" "/usr/share/locale" "ko:ja:zh"
>     into
>         "/usr/lib/gtk-2.0/2.4.0/immodules/im-xim.so"
>         "xim" "X Input Method" "gtk20" "/usr/share/locale"
>         "ko:ja:th:zh:it"

I don't know about that.. about that, why edit them?

> 14) I rebooted Linux
> 15) I did '$ scim -d'
> 16) I ran Emacs and typed "CTRL+SPACE" to turn on SCIM.

hope to you make Good luck.


More information about the scim mailing list