[Spice-devel] [PATCH 15/18] server/red_worker: s/handle_message_proc/handle_parsed_proc/
Marc-André Lureau
marcandre.lureau at gmail.com
Tue Feb 8 13:00:07 PST 2011
(to merge with patch 13)
Perhaps channel_handle_parsed_proc instead?
Also, I suppose you should rename RedChannel.handle_message to
RedChannel.handle_parsed
On Mon, Feb 7, 2011 at 7:20 PM, Alon Levy <alevy at redhat.com> wrote:
> Signature changed to red_channel's handle_parsed_proc, and rename to same,
> towards reuse of RedChannel.
> ---
> server/red_worker.c | 10 +++++-----
> 1 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/server/red_worker.c b/server/red_worker.c
> index 5c02518..70ec871 100644
> --- a/server/red_worker.c
> +++ b/server/red_worker.c
> @@ -351,7 +351,7 @@ typedef struct RedChannel RedChannel;
> typedef void (*channel_disconnect_proc)(RedChannel *channel);
> typedef void (*channel_hold_pipe_item_proc)(PipeItem *item);
> typedef void (*release_item_proc)(RedChannel *channel, void *item);
> -typedef int (*handle_message_proc)(RedChannel *channel, size_t size, uint32_t type, void *message);
> +typedef int (*handle_parsed_proc)(RedChannel *channel, uint32_t size, uint16_t type, void *message);
>
> struct RedChannel {
> spice_parse_channel_func_t parser;
> @@ -388,7 +388,7 @@ struct RedChannel {
> channel_disconnect_proc disconnect;
> channel_hold_pipe_item_proc hold_item;
> release_item_proc release_item;
> - handle_message_proc handle_message;
> + handle_parsed_proc handle_message;
> #ifdef RED_STATISTICS
> uint64_t *out_bytes_counter;
> #endif
> @@ -8940,7 +8940,7 @@ static void on_new_display_channel(RedWorker *worker)
> }
> }
>
> -static int channel_handle_message(RedChannel *channel, size_t size, uint32_t type, void *message)
> +static int channel_handle_message(RedChannel *channel, uint32_t size, uint16_t type, void *message)
> {
> switch (type) {
> case SPICE_MSGC_ACK_SYNC:
> @@ -9247,7 +9247,7 @@ static int display_channel_handle_migrate_data(DisplayChannel *channel, size_t s
> return TRUE;
> }
>
> -static int display_channel_handle_message(RedChannel *channel, size_t size, uint32_t type, void *message)
> +static int display_channel_handle_message(RedChannel *channel, uint32_t size, uint16_t type, void *message)
> {
> switch (type) {
> case SPICE_MSGC_DISPLAY_INIT:
> @@ -9351,7 +9351,7 @@ static RedChannel *__new_channel(RedWorker *worker, int size, uint32_t channel_i
> channel_disconnect_proc disconnect,
> channel_hold_pipe_item_proc hold_item,
> release_item_proc release_item,
> - handle_message_proc handle_message)
> + handle_parsed_proc handle_message)
> {
> struct epoll_event event;
> RedChannel *channel;
> --
> 1.7.4
>
> _______________________________________________
> Spice-devel mailing list
> Spice-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/spice-devel
>
--
Marc-André Lureau
More information about the Spice-devel
mailing list