[Spice-devel] [PATCH 13/18] server/red_worker: s/disconnect_channel_proc/channel_disconnect_proc/
Marc-André Lureau
marcandre.lureau at gmail.com
Tue Feb 8 13:00:22 PST 2011
hmm, again, it's obvious that there is a problem of naming and
consistency in the code. Just modifying one makes perhaps things
worst.. what about? :
hold_pipe_item_proc -> pipe_item_hold_proc
release_item_proc -> channel_release_item_proc
handle_message_proc -> channel_handle_message_proc
So, I see you do rename some of them in the following patch. I would
squash all those rename in this patch.
On Mon, Feb 7, 2011 at 7:20 PM, Alon Levy <alevy at redhat.com> wrote:
> ---
> server/red_worker.c | 6 +++---
> 1 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/server/red_worker.c b/server/red_worker.c
> index 1574b99..355e073 100644
> --- a/server/red_worker.c
> +++ b/server/red_worker.c
> @@ -348,7 +348,7 @@ typedef struct LocalCursor {
> #define PALETTE_CACHE_HASH_KEY(id) ((id) & PALETTE_CACHE_HASH_MASK)
>
> typedef struct RedChannel RedChannel;
> -typedef void (*disconnect_channel_proc)(RedChannel *channel);
> +typedef void (*channel_disconnect_proc)(RedChannel *channel);
> typedef void (*hold_pipe_item_proc)(PipeItem *item);
> typedef void (*release_item_proc)(RedChannel *channel, void *item);
> typedef int (*handle_message_proc)(RedChannel *channel, size_t size, uint32_t type, void *message);
> @@ -385,7 +385,7 @@ struct RedChannel {
> uint8_t *end;
> } recive_data;
>
> - disconnect_channel_proc disconnect;
> + channel_disconnect_proc disconnect;
> hold_pipe_item_proc hold_item;
> release_item_proc release_item;
> handle_message_proc handle_message;
> @@ -9348,7 +9348,7 @@ static void free_common_channel_from_listener(EventListener *ctx)
> static RedChannel *__new_channel(RedWorker *worker, int size, uint32_t channel_id,
> RedsStreamContext *peer, int migrate,
> event_listener_action_proc handler,
> - disconnect_channel_proc disconnect,
> + channel_disconnect_proc disconnect,
> hold_pipe_item_proc hold_item,
> release_item_proc release_item,
> handle_message_proc handle_message)
> --
> 1.7.4
>
> _______________________________________________
> Spice-devel mailing list
> Spice-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/spice-devel
>
--
Marc-André Lureau
More information about the Spice-devel
mailing list