[Spice-devel] [PATCH 10/18] server/red_worker: use red_channel begin_send_message
Marc-André Lureau
marcandre.lureau at gmail.com
Tue Feb 8 13:01:09 PST 2011
well... ack, but obviously while you are at it, you could rename the
rest as well?, they are plenty, for instance:
red_receive(RedChannel *channel); -> red_channel_receive
red_release_pixmap_cache(DisplayChannel *channel); ->
red_display_release_pixmap_cache
display_begin_send_message(DisplayChannel *channel); ->
red_display_begin_send_message
display_channel_push_release(DisplayChannel *channel, ...) ->
red_display_channel_push_release
red_release_pixmap_cache(DisplayChannel *channel); -> red_display...
red_release_glz(DisplayChannel *channel); -> red_display...
red_freeze_glz(DisplayChannel *channel); -> red_display...
so many that are badly prefixed or with bad arguments type/signature..
Is it worth starting renaming one?
On Mon, Feb 7, 2011 at 7:20 PM, Alon Levy <alevy at redhat.com> wrote:
> s/red_begin_send_message/red_channel_begin_send_message/
> ---
> server/red_worker.c | 24 ++++++++++++------------
> 1 files changed, 12 insertions(+), 12 deletions(-)
>
> diff --git a/server/red_worker.c b/server/red_worker.c
> index 393543a..fb04ed9 100644
> --- a/server/red_worker.c
> +++ b/server/red_worker.c
> @@ -976,7 +976,7 @@ static void red_display_release_stream(DisplayChannel *display, StreamAgent *age
> static inline void red_detach_stream(RedWorker *worker, Stream *stream);
> static void red_stop_stream(RedWorker *worker, Stream *stream);
> static inline void red_stream_maintenance(RedWorker *worker, Drawable *candidate, Drawable *sect);
> -static inline void red_begin_send_message(RedChannel *channel);
> +static inline void red_channel_begin_send_message(RedChannel *channel);
> static inline void display_begin_send_message(DisplayChannel *channel);
> static void red_receive(RedChannel *channel);
> static void red_release_pixmap_cache(DisplayChannel *channel);
> @@ -7396,7 +7396,7 @@ static void display_channel_push_release(DisplayChannel *channel, uint8_t type,
> free_list->res->resources[free_list->res->count++].id = id;
> }
>
> -static inline void red_begin_send_message(RedChannel *channel)
> +static inline void red_channel_begin_send_message(RedChannel *channel)
> {
> spice_marshaller_flush(channel->send_data.marshaller);
> channel->send_data.size = spice_marshaller_get_total_size(channel->send_data.marshaller);
> @@ -7453,7 +7453,7 @@ static inline void display_begin_send_message(DisplayChannel *channel)
> spice_marshaller_add_uint32(sub_list_m, spice_marshaller_get_offset(inval_m));
> channel->common.base.send_data.header->sub_list = spice_marshaller_get_offset(sub_list_m);
> }
> - red_begin_send_message((RedChannel *)channel);
> + red_channel_begin_send_message((RedChannel *)channel);
> }
>
> static inline RedChannel *red_ref_channel(RedChannel *channel)
> @@ -7769,14 +7769,14 @@ static void red_send_set_ack(RedChannel *channel)
>
> spice_marshall_msg_set_ack(channel->send_data.marshaller, &ack);
>
> - red_begin_send_message(channel);
> + red_channel_begin_send_message(channel);
> }
>
> static inline void red_send_verb(RedChannel *channel, uint16_t verb)
> {
> ASSERT(channel);
> red_channel_init_send_data(channel, verb, NULL);
> - red_begin_send_message(channel);
> + red_channel_begin_send_message(channel);
> }
>
> static inline void display_send_verb(DisplayChannel *channel, uint16_t verb)
> @@ -7799,7 +7799,7 @@ static inline void __red_send_inval(RedChannel *channel, CacheItem *cach_item)
> static void red_send_inval(RedChannel *channel, CacheItem *cach_item)
> {
> __red_send_inval(channel, cach_item);
> - red_begin_send_message(channel);
> + red_channel_begin_send_message(channel);
> }
>
> static void red_display_send_inval(DisplayChannel *display_channel, CacheItem *cach_item)
> @@ -8158,7 +8158,7 @@ static void red_send_cursor_init(CursorChannel *channel)
> spice_marshall_msg_cursor_init(channel->common.base.send_data.marshaller, &msg);
> add_buf_from_info(&channel->common.base, channel->common.base.send_data.marshaller, &info);
>
> - red_begin_send_message(&channel->common.base);
> + red_channel_begin_send_message(&channel->common.base);
> }
>
> static void red_send_local_cursor(CursorChannel *cursor_channel, LocalCursor *cursor)
> @@ -8179,7 +8179,7 @@ static void red_send_local_cursor(CursorChannel *cursor_channel, LocalCursor *cu
> spice_marshall_msg_cursor_set(channel->send_data.marshaller, &cursor_set);
> add_buf_from_info(channel, channel->send_data.marshaller, &info);
>
> - red_begin_send_message(channel);
> + red_channel_begin_send_message(channel);
>
> red_release_cursor(cursor_channel->common.worker, (CursorItem *)cursor);
> }
> @@ -8192,7 +8192,7 @@ static void cursor_channel_send_migrate(CursorChannel *cursor_channel)
> migrate.flags = 0;
>
> spice_marshall_msg_migrate(cursor_channel->common.base.send_data.marshaller, &migrate);
> - red_begin_send_message((RedChannel*)cursor_channel);
> + red_channel_begin_send_message((RedChannel*)cursor_channel);
> }
>
> static void red_send_cursor(CursorChannel *cursor_channel, CursorItem *cursor)
> @@ -8249,7 +8249,7 @@ static void red_send_cursor(CursorChannel *cursor_channel, CursorItem *cursor)
> red_error("bad cursor command %d", cmd->type);
> }
>
> - red_begin_send_message(channel);
> + red_channel_begin_send_message(channel);
>
> red_release_cursor(cursor_channel->common.worker, cursor);
> }
> @@ -8266,7 +8266,7 @@ static void red_send_surface_create(DisplayChannel *display, SpiceMsgSurfaceCrea
>
> spice_marshall_msg_display_surface_create(channel->send_data.marshaller, surface_create);
>
> - red_begin_send_message(channel);
> + red_channel_begin_send_message(channel);
> }
>
> static void red_send_surface_destroy(DisplayChannel *display, uint32_t surface_id)
> @@ -8284,7 +8284,7 @@ static void red_send_surface_destroy(DisplayChannel *display, uint32_t surface_i
>
> spice_marshall_msg_display_surface_destroy(channel->send_data.marshaller, &surface_destroy);
>
> - red_begin_send_message(channel);
> + red_channel_begin_send_message(channel);
> }
>
> static inline PipeItem *red_pipe_get(RedChannel *channel)
> --
> 1.7.4
>
> _______________________________________________
> Spice-devel mailing list
> Spice-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/spice-devel
>
--
Marc-André Lureau
More information about the Spice-devel
mailing list