[Spice-devel] [PATCH v2 00/13] red_channel introducing refactoring, part 2

Marc-André Lureau marcandre.lureau at gmail.com
Fri Feb 11 04:07:42 PST 2011


Hi

So ACK for everything except 11/13, this rename:

    s/hold_pipe_item_proc/channel_pipe_item_hold_proc/

It gives this inconsistency:

-typedef void (*channel_hold_pipe_item_proc)(PipeItem *item);
+typedef void (*channel_pipe_item_hold_proc)(PipeItem *item);
 typedef void (*channel_release_pipe_item_proc)(RedChannel *channel,
                                                PipeItem *item, int
item_pushed);

Even if channel is not used by channel_pipe_item_hold_proc, it could,
I mean, it's a callback with different possible implementations, I
think it would be better wihtout rename:

typedef void (*channel_hold_pipe_item_proc)(RedChannel *channel,
PipeItem *item);
typedef void (*channel_release_pipe_item_proc)(RedChannel *channel,
                                                PipeItem *item, int
item_pushed);

On Thu, Feb 10, 2011 at 5:09 PM, Alon Levy <alevy at redhat.com> wrote:
> v2: (Marc-Andre review)
>  * squashed renames
>  * squashed CommonChannel introduction and free cb addition
>  * small fix from gcc 4.6.0
>  * not addressed:
>  * left CONTAINEROF for now
>
> This is a part of a much larger series so I don't have a good concise
> description. Ultimately this all leads to a reuse of RedChannel across
> most of the channels (sound remains an odd out because of not using a
> pipe abstraction, but a bitmap of outstanding packets, you can have 0
> or one of each type waiting to be sent, this makes sense for audio.
> Probably for video too actually).
>
> Anyway this patchset touches almost only red_worker (and it's helper
> cache files, split out because they are used for a number of different
> caches via macros before inclusion, that usual trick). It is mostly about
> renaming, making a CommonChannel take the place of the internal RedChannel
> to allow future use of the external RedChannel defined in red_channel.h
>
> Alon Levy (13):
>  server/red_worker: change hold_item sig, drop the void*
>  server/red_worker: use ack_data struct
>  server/red_worker: introduce CommonChannel
>  server/red_worker: shorten some lines using alias variables
>  server/red_worker: use red_channel pipe add versions
>  server/red_worker: extract common_release_pipe_item from
>    red_pipe_clear
>  server/red_worker: split display_channel_send_item
>  server/red_worker: add red_channel_init_send_data
>  server/red_worker: use red_channel begin_send_message
>  server/red_worker: split cursor_channel_send_item
>  server/red_worker: renames to add channel_ prefix
>  server/red_worker: introduce an outgoing struct around
>    out_bytes_counter
>  server/red_worker: match channel_release_pipe_item_proc to
>    red_channel
>
>  server/red_channel.c             |    4 +-
>  server/red_channel.h             |    8 +-
>  server/red_client_cache.h        |    2 +-
>  server/red_client_shared_cache.h |   20 +-
>  server/red_worker.c              | 1022 ++++++++++++++++++++------------------
>  5 files changed, 561 insertions(+), 495 deletions(-)
>
> --
> 1.7.4
>
> _______________________________________________
> Spice-devel mailing list
> Spice-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/spice-devel
>



-- 
Marc-André Lureau


More information about the Spice-devel mailing list