[Spice-devel] [spice-gtk Win32 v4 03/17] Make SpiceUsbDevice a box for SpiceUsbDeviceInfo, instead of a box for libusb_device
Marc-André Lureau
marcandre.lureau at gmail.com
Thu Jul 5 14:46:21 PDT 2012
On Thu, Jul 5, 2012 at 11:26 PM, Marc-André Lureau
<marcandre.lureau at gmail.com> wrote:
> On Thu, Jul 5, 2012 at 10:43 PM, Uri Lublin <uril at redhat.com> wrote:
>> + gboolean filter_ok = FALSE;
>
> Actually, I think "auto_ok" was a more readable name here, since it
> affects only the "auto" code path.
>
> --
> Marc-André Lureau
+ if (can_redirect && filter_ok) {
spice_usb_device_manager_connect_device_async(self,
- (SpiceUsbDevice *)device, NULL,
+ device, NULL,
spice_usb_device_manager_auto_connect_cb,
- libusb_ref_device(device));
+ g_object_ref(device));
+ }
Is the g_object_ref() is a left over from a previous version ?
--
Marc-André Lureau
More information about the Spice-devel
mailing list