[Spice-devel] [spice-gtk v3 09/19] log: nitpick at channel name in CHANNEL_DEBUG
Victor Toso
victortoso at redhat.com
Sat Mar 12 14:32:10 UTC 2016
After moving to spice_debug, all logs are always prefixed with file
name, function and line where CHANNEL_DEBUG was called.
The channel-name now does not stand out as much as it should because
name + colon is a common pattern. Enclosing the name between parentheses
does help
---
src/spice-channel-priv.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/spice-channel-priv.h b/src/spice-channel-priv.h
index c1ffb0d..d816e6c 100644
--- a/src/spice-channel-priv.h
+++ b/src/spice-channel-priv.h
@@ -41,7 +41,7 @@ G_BEGIN_DECLS
#define MAX_SPICE_DATA_HEADER_SIZE sizeof(SpiceDataHeader)
#define CHANNEL_DEBUG(channel, fmt, ...) \
- spice_debug("%s: " fmt, SPICE_CHANNEL(channel)->priv->name, ## __VA_ARGS__)
+ spice_debug("(%s) " fmt, SPICE_CHANNEL(channel)->priv->name, ## __VA_ARGS__)
struct _SpiceMsgOut {
int refcount;
--
2.5.0
More information about the Spice-devel
mailing list