[Spice-devel] [spice-server PATCH 1/8] current_remove: rename internal variable 'container'

Uri Lublin uril at redhat.com
Sun Oct 16 11:44:48 UTC 2016


It shadows the outer one.

Signed-off-by: Uri Lublin <uril at redhat.com>
---

Possibly more meaningful names than container and container2
should be used

---
 server/display-channel.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/server/display-channel.c b/server/display-channel.c
index b9366b5..49650e1 100644
--- a/server/display-channel.c
+++ b/server/display-channel.c
@@ -359,16 +359,16 @@ static void current_remove(DisplayChannel *display, TreeItem *item)
             drawable_remove_from_pipes(drawable);
             current_remove_drawable(display, drawable);
         } else {
-            Container *container = CONTAINER(now);
+            Container *container2 = CONTAINER(now);
 
             spice_assert(now->type == TREE_ITEM_TYPE_CONTAINER);
 
-            if ((ring_item = ring_get_head(&container->items))) {
+            if ((ring_item = ring_get_head(&container2->items))) {
                 now = SPICE_CONTAINEROF(ring_item, TreeItem, siblings_link);
                 continue;
             }
             ring_item = now->siblings_link.prev;
-            container_free(container);
+            container_free(container2);
         }
         if (now == item) {
             return;
-- 
2.7.4



More information about the Spice-devel mailing list