[Spice-devel] [PATCH 07/18] Rename red_surface to surface
Christophe Fergeau
cfergeau at redhat.com
Tue Sep 27 12:24:45 UTC 2016
Commit log could mention that this can now be used because of the
previous commit which did s/surface/surface_cmd (but it's also ok
unchanged).
Acked-by: Christophe Fergeau <cfergeau at redhat.com>
On Mon, Sep 26, 2016 at 09:12:40AM +0100, Frediano Ziglio wrote:
> Attempt to use consistent naming.
> Usually we use surface name for RedSurface.
>
> Signed-off-by: Frediano Ziglio <fziglio at redhat.com>
> ---
> server/display-channel.c | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/server/display-channel.c b/server/display-channel.c
> index ad9dde6..217f5eb 100644
> --- a/server/display-channel.c
> +++ b/server/display-channel.c
> @@ -1964,7 +1964,7 @@ void display_channel_process_surface_cmd(DisplayChannel *display,
> int loadvm)
> {
> uint32_t surface_id;
> - RedSurface *red_surface;
> + RedSurface *surface;
> uint8_t *data;
>
> surface_id = surface_cmd->surface_id;
> @@ -1972,7 +1972,7 @@ void display_channel_process_surface_cmd(DisplayChannel *display,
> return;
> }
>
> - red_surface = &display->priv->surfaces[surface_id];
> + surface = &display->priv->surfaces[surface_id];
>
> switch (surface_cmd->type) {
> case QXL_SURFACE_CMD_CREATE: {
> @@ -1980,7 +1980,7 @@ void display_channel_process_surface_cmd(DisplayChannel *display,
> int32_t stride = surface_cmd->u.surface_create.stride;
> int reloaded_surface = loadvm || (surface_cmd->flags & QXL_SURF_FLAG_KEEP_DATA);
>
> - if (red_surface->refs) {
> + if (surface->refs) {
> spice_warning("avoiding creating a surface twice");
> break;
> }
> @@ -1995,15 +1995,15 @@ void display_channel_process_surface_cmd(DisplayChannel *display,
> reloaded_surface,
> // reloaded surfaces will be sent on demand
> !reloaded_surface);
> - red_surface->create = surface_cmd->release_info_ext;
> + surface->create = surface_cmd->release_info_ext;
> break;
> }
> case QXL_SURFACE_CMD_DESTROY:
> - if (!red_surface->refs) {
> + if (!surface->refs) {
> spice_warning("avoiding destroying a surface twice");
> break;
> }
> - red_surface->destroy = surface_cmd->release_info_ext;
> + surface->destroy = surface_cmd->release_info_ext;
> display_channel_destroy_surface(display, surface_id);
> break;
> default:
> --
> 2.7.4
>
> _______________________________________________
> Spice-devel mailing list
> Spice-devel at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/spice-devel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/spice-devel/attachments/20160927/086b3b61/attachment.sig>
More information about the Spice-devel
mailing list