[Spice-devel] [spice-server 2/2] cursor: Rename cursor_marshall to red_marshall_cursor_command
Frediano Ziglio
fziglio at redhat.com
Wed Apr 11 17:16:57 UTC 2018
>
> The name is more consistent with red_marshall_cursor_init.
> ---
> server/cursor-channel.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
Why command (so red_marshall_cursor) ?
The item is RED_PIPE_ITEM_TYPE_CURSOR.
> diff --git a/server/cursor-channel.c b/server/cursor-channel.c
> index 522261e3f..a549c5fe0 100644
> --- a/server/cursor-channel.c
> +++ b/server/cursor-channel.c
> @@ -142,9 +142,9 @@ static void red_marshall_cursor_init(CursorChannelClient
> *ccc, SpiceMarshaller *
> spice_marshall_msg_cursor_init(base_marshaller, &msg);
> }
>
> -static void cursor_marshall(CursorChannelClient *ccc,
> - SpiceMarshaller *m,
> - RedCursorPipeItem *cursor_pipe_item)
> +static void red_marshall_cursor_command(CursorChannelClient *ccc,
> + SpiceMarshaller *m,
> + RedCursorPipeItem *cursor_pipe_item)
> {
> RedChannelClient *rcc = RED_CHANNEL_CLIENT(ccc);
> CursorChannel *cursor_channel =
> CURSOR_CHANNEL(red_channel_client_get_channel(rcc));
> @@ -212,7 +212,7 @@ static void cursor_channel_send_item(RedChannelClient
> *rcc, RedPipeItem *pipe_it
>
> switch (pipe_item->type) {
> case RED_PIPE_ITEM_TYPE_CURSOR:
> - cursor_marshall(ccc, m, SPICE_UPCAST(RedCursorPipeItem, pipe_item));
> + red_marshall_cursor_command(ccc, m, SPICE_UPCAST(RedCursorPipeItem,
> pipe_item));
> break;
> case RED_PIPE_ITEM_TYPE_INVAL_ONE:
> red_marshall_inval(rcc, m, SPICE_CONTAINEROF(pipe_item,
> RedCacheItem, u.pipe_data));
Frediano
More information about the Spice-devel
mailing list