[Spice-devel] [spice-server 05/10] qxl: Rename 'qxl' to 'qxl_cmd' in red_get_cursor_cmd()

Frediano Ziglio fziglio at redhat.com
Mon Apr 16 10:58:18 UTC 2018


> 
> This is in preparation for next commit
> ---
>  server/red-parse-qxl.c | 20 ++++++++++----------
>  1 file changed, 10 insertions(+), 10 deletions(-)
> 
> diff --git a/server/red-parse-qxl.c b/server/red-parse-qxl.c
> index 80746ecbb..c08d18160 100644
> --- a/server/red-parse-qxl.c
> +++ b/server/red-parse-qxl.c
> @@ -1460,28 +1460,28 @@ static void red_put_cursor(SpiceCursor *red)
>  bool red_get_cursor_cmd(RedMemSlotInfo *slots, int group_id,
>                          RedCursorCmd *red, QXLPHYSICAL addr)
>  {
> -    QXLCursorCmd *qxl;
> +    QXLCursorCmd *qxl_cmd;
>      int error;
>  
> -    qxl = (QXLCursorCmd *)memslot_get_virt(slots, addr, sizeof(*qxl),
> group_id, &error);
> +    qxl_cmd = (QXLCursorCmd *)memslot_get_virt(slots, addr,
> sizeof(*qxl_cmd), group_id, &error);
>      if (error) {
>          return false;
>      }
> -    red->release_info_ext.info      = &qxl->release_info;
> +    red->release_info_ext.info      = &qxl_cmd->release_info;
>      red->release_info_ext.group_id  = group_id;
>  
> -    red->type = qxl->type;
> +    red->type = qxl_cmd->type;
>      switch (red->type) {
>      case QXL_CURSOR_SET:
> -        red_get_point16_ptr(&red->u.set.position, &qxl->u.set.position);
> -        red->u.set.visible  = qxl->u.set.visible;
> -        return red_get_cursor(slots, group_id,  &red->u.set.shape,
> qxl->u.set.shape);
> +        red_get_point16_ptr(&red->u.set.position, &qxl_cmd->u.set.position);
> +        red->u.set.visible  = qxl_cmd->u.set.visible;
> +        return red_get_cursor(slots, group_id,  &red->u.set.shape,
> qxl_cmd->u.set.shape);
>      case QXL_CURSOR_MOVE:
> -        red_get_point16_ptr(&red->u.position, &qxl->u.position);
> +        red_get_point16_ptr(&red->u.position, &qxl_cmd->u.position);
>          break;
>      case QXL_CURSOR_TRAIL:
> -        red->u.trail.length    = qxl->u.trail.length;
> -        red->u.trail.frequency = qxl->u.trail.frequency;
> +        red->u.trail.length    = qxl_cmd->u.trail.length;
> +        red->u.trail.frequency = qxl_cmd->u.trail.frequency;
>          break;
>      }
>      return true;

Don't like this, lot of structures in this file use "qxl", for coherence
I would change all or nothing but changing all would mean a lot of changes
with not much value

Frediano


More information about the Spice-devel mailing list