[Spice-devel] [PATCH spice-server v2] style: Update style to include some C++ element

Frediano Ziglio fziglio at redhat.com
Wed Feb 7 10:21:33 UTC 2018


These style are used by other SPICE projects like spice-streaming-agent.
See discussion "Coding style and naming conventions for C++" at
https://lists.freedesktop.org/archives/spice-devel/2018-January/041562.html.

Signed-off-by: Frediano Ziglio <fziglio at redhat.com>
---
 docs/spice_style.txt | 54 +++++++++++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 53 insertions(+), 1 deletion(-)

Changes in v2:
- more details for namespace usages;
- specify C++ dialect;
- fix class indentation.

diff --git a/docs/spice_style.txt b/docs/spice_style.txt
index eb0e30ef..6daa41d2 100644
--- a/docs/spice_style.txt
+++ b/docs/spice_style.txt
@@ -1,7 +1,7 @@
 Spice project coding style and coding conventions
 =================================================
 
-Copyright (C) 2009-2016 Red Hat, Inc.
+Copyright (C) 2009-2018 Red Hat, Inc.
 Licensed under a Creative Commons Attribution-Share Alike 3.0
 United States License (see http://creativecommons.org/licenses/by-sa/3.0/us/legalcode).
 
@@ -379,3 +379,55 @@ Also in source (no header) files you must include `config.h` at the beginning so
 
 #include "spice_server.h"
 ----
+
+C++
+---
+C\++ follows C style if not specified otherwise.
+The C+\+11 dialect is assumed by default. No attempts will be made to
+restrict the code to older variants of C+\+.
+For compatibility reasons don't use more recent C++ dialects.
+
+Method names
+~~~~~~~~~~~~
+
+Method names should use lower case and separate words with
+underscores.
+
+
+Namespaces
+~~~~~~~~~~
+
+Namespaces should use lower case and separate words with underscores.
+Namespace blocks should not increase indentation.
+Namespaces can be nested. Namespace closing brackets for nested
+namespaces can be placed together on the same line, but for
+readability reasons the closure should specify the namespace with a
+comment.
+
+[source,cpp]
+----
+namespace spice {
+namespace streaming_agent {
+
+class ClassInsideNamespace {
+...
+};
+
+}} // namespace spice::streaming_agent
+----
+
+The `using namespace` construct should never be used in headers. It should
+be used sparingly in source files, and only within the body of short
+functions.
+
+Preferred alternatives to `using namespace` include:
+
+* using declarations
++
+[source,cpp]
+using spice::streaming_agent::some_class;
++
+* namespace aliases
++
+[source,cpp]
+namespace ssa = spice::streaming_agent;
-- 
2.14.3



More information about the Spice-devel mailing list