[Spice-devel] [PATCH 08/17] Use C++ style for cursor message initialization instead of C style
Lukáš Hrázký
lhrazky at redhat.com
Mon Feb 19 18:25:52 UTC 2018
On Fri, 2018-02-16 at 17:15 +0100, Christophe de Dinechin wrote:
> From: Christophe de Dinechin <dinechin at redhat.com>
>
> Signed-off-by: Christophe de Dinechin <dinechin at redhat.com>
> ---
> src/spice-streaming-agent.cpp | 47 +++++++++++++++++++++++++------------------
> 1 file changed, 27 insertions(+), 20 deletions(-)
>
> diff --git a/src/spice-streaming-agent.cpp b/src/spice-streaming-agent.cpp
> index 1e19e43..720173a 100644
> --- a/src/spice-streaming-agent.cpp
> +++ b/src/spice-streaming-agent.cpp
> @@ -285,38 +285,45 @@ static void usage(const char *progname)
> }
>
> static void
> -send_cursor(int streamfd, unsigned width, unsigned height, int hotspot_x, int hotspot_y,
> +send_cursor(int streamfd,
> + uint16_t width, uint16_t height,
> + uint16_t hotspot_x, uint16_t hotspot_y,
> std::function<void(uint32_t *)> fill_cursor)
> {
> if (width >= STREAM_MSG_CURSOR_SET_MAX_WIDTH ||
> height >= STREAM_MSG_CURSOR_SET_MAX_HEIGHT)
> return;
>
> - size_t cursor_size =
> - sizeof(StreamDevHeader) + sizeof(StreamMsgCursorSet) +
> - width * height * sizeof(uint32_t);
> - std::unique_ptr<uint8_t[]> msg(new uint8_t[cursor_size]);
> + const uint32_t cursor_msgsize =
> + sizeof(SpiceStreamCursorMessage) + width * height * sizeof(uint32_t);
> + const uint32_t hdrsize = sizeof(StreamDevHeader);
Seems like inconsistent naming "cursor_msgsize" vs "hdrsize", two
spaces before =, maybe the sizeof(StreamDevHeader) could be used
directly below.
> - StreamDevHeader &dev_hdr(*reinterpret_cast<StreamDevHeader*>(msg.get()));
> - memset(&dev_hdr, 0, sizeof(dev_hdr));
> - dev_hdr.protocol_version = STREAM_DEVICE_PROTOCOL;
> - dev_hdr.type = STREAM_TYPE_CURSOR_SET;
> - dev_hdr.size = cursor_size - sizeof(StreamDevHeader);
> + std::unique_ptr<uint8_t[]> storage(new uint8_t[cursor_msgsize]);
>
> - StreamMsgCursorSet &cursor_msg(*reinterpret_cast<StreamMsgCursorSet *>(msg.get() + sizeof(StreamDevHeader)));
> - memset(&cursor_msg, 0, sizeof(cursor_msg));
> -
> - cursor_msg.type = SPICE_CURSOR_TYPE_ALPHA;
> - cursor_msg.width = width;
> - cursor_msg.height = height;
> - cursor_msg.hot_spot_x = hotspot_x;
> - cursor_msg.hot_spot_y = hotspot_y;
> + SpiceStreamCursorMessage *cursor_msg =
> + new(storage.get()) SpiceStreamCursorMessage {
> + .hdr = {
> + .protocol_version = STREAM_DEVICE_PROTOCOL,
> + .padding = 0, // Workaround GCC internal / not implemented compiler error
> + .type = STREAM_TYPE_CURSOR_SET,
> + .size = cursor_msgsize - hdrsize
> + },
> + .msg = {
> + .width = width,
> + .height = height,
> + .hot_spot_x = hotspot_x,
> + .hot_spot_y = hotspot_y,
> + .type = SPICE_CURSOR_TYPE_ALPHA,
> + .padding1 = { },
> + .data = { }
> + }
> + };
>
> - uint32_t *pixels = reinterpret_cast<uint32_t *>(cursor_msg.data);
> + uint32_t *pixels = reinterpret_cast<uint32_t *>(cursor_msg->msg.data);
> fill_cursor(pixels);
>
> std::lock_guard<std::mutex> stream_guard(stream_mtx);
> - write_all(streamfd, msg.get(), cursor_size);
> + write_all(streamfd, storage.get(), cursor_msgsize);
> }
>
> static void cursor_changes(int streamfd, Display *display, int event_base)
More information about the Spice-devel
mailing list