[Spice-devel] [PATCH vdagent v2 0/1] clipboard system redesign
Jakub Janků
janku.jakub.jj at gmail.com
Mon Feb 26 19:01:27 UTC 2018
Changes since v1:
- keep old Xlib implementation for now
- make get_type_from_atom() more readable
- refactor of weak ref functions (new_request_ref(), free_request_ref(), ...)
- pack selection-dependant variables from VDAgentClipboards into struct Selection
- several renames
- DataRetrieval --> AppRequest
- data_retrievals --> requests_from_apps
- data_requests --> requests_from_client
- sel_from_clip --> sel_id_from_clip
- minor style improvements
Jakub Janků (1):
vdagent: add GTK+ clipboard handling
Makefile.am | 6 +
configure.ac | 11 ++
src/vdagent/clipboard.c | 430 ++++++++++++++++++++++++++++++++++++++++++++++++
src/vdagent/clipboard.h | 42 +++++
src/vdagent/vdagent.c | 53 +++++-
src/vdagent/x11-priv.h | 20 +++
src/vdagent/x11.c | 30 +++-
src/vdagent/x11.h | 6 +
8 files changed, 590 insertions(+), 8 deletions(-)
create mode 100644 src/vdagent/clipboard.c
create mode 100644 src/vdagent/clipboard.h
--
2.14.3
More information about the Spice-devel
mailing list