[Swfdec] swfdec in firefox on Fedora8 x86_64

Peter Robinson pbrobinson at gmail.com
Thu Nov 8 06:35:14 PST 2007

> On Nov 8, 2007 2:19 PM, Peter Robinson <pbrobinson at gmail.com> wrote:
> > I've tried swfdec on Fedora 8 x86_64 without much luck. I originally
> > used the rpms from livna. I primarily want it just to view youtube
> > videos which from various blog posts I thought worked. It seems to
> > detect the flash but i just get a white background (it does detect a
> > plugin as you don't get the jigsaw piece).
> >
> There have been reports from Gentoo on IRC about the same thing. It
> turned out they used Xorg 7.3 and that has a bug in it that prevented
> the videos from being shown. According to them Xorg 7.2 and Xorg git
> work fine. So if you use Xorg 7.3, you may be hit by the same issue.
> In that case no Swfdec recompile will help you. I don't know more
> about this, but maybe someone who was affected can answer in more
> detail?

Hmm. F8 is using a bit of xorg 7.3 plus xserver 1.3 (not 1.4) so bits
of each as I believe the xserver 1.4 release wasn't overly stable, do
you know of a bug report somewhere for it where I can try and find out
more info about it?

> > From there I checked out a copy from the git repo but i can't compile
> > it due to the error below (either as a rpm or from straight source).
> >
> It's a known problem that rpm adds a -Wall flag. Unfortunately this
> reactivates a warning that we explicitly turned off by using
> -Wno-unused-parameter. If your non-rpm compile gets hit by the same
> issue, you probably have -Wall in your CFLAGS, too. To get around
> this, you have to add -Wno-unused-parameter to your CFLAGS _after_ the
> -Wall. Alternatively, you can add -Wno-error to get around gcc
> aborting on warnings.

Version 0.5.3 compiles either way fine but git doesn't so its been a
regression since then.

Oh well looks like I'm going to have to wait until F9 for any form of
flash then.


More information about the Swfdec mailing list