[systemd-devel] Questions/problems about distro integrating

Lennart Poettering lennart at poettering.net
Mon Nov 22 11:32:54 PST 2010

On Mon, 22.11.10 14:03, Ozan Çağlayan (ozan at pardus.org.tr) wrote:

> Pazartesi 22 Kasım 2010 günü (saat 12:42:07) Andrey Borzenkov şunları 
> yazmıştı:
> > 
> > {pts/0}% sudo mount -o remount,ro /datastore
> > {pts/0}% LC_ALL=C sudo swapon -p 0 /datastore/nsr/test
> > swapon: /datastore/nsr/test: swapon failed: Read-only file system
> > {pts/0}% echo $?
> > 255
> Hm yes it seems there's an ordering issue as swap.target doesn't explicitly 
> depend on remount-rootfs.service. I now tried your example and swapon returned 
> 255 as well.
> I tried writing After=remount-rootfs.service into swap.target but this doesn't 
> seem to work too.

Hmm, yepp, systemd starts things as early as possible, and you'd have to
order the .swap unit here properly, not swap.target.

Since the .swap unit is automatically created from fstab I guess I have
to change systemd itself to implicitly create an order dep between
file-based .swap units in remount-rootfs.service.


Lennart Poettering - Red Hat, Inc.

More information about the systemd-devel mailing list