[systemd-devel] encrypted /var with systemd - impossible?

Lennart Poettering lennart at poettering.net
Fri Jul 1 15:24:54 PDT 2011

On Tue, 28.06.11 22:40, yoshi watanabe (yoshi314 at gmail.com) wrote:

> reinstalled and got reproductible environment with the error.
> first, i tried booting with dracut luks management with default
> parameters. first thing i noticed, dracut didn't ask for cryptsetup
> password. i suppose that if / is not encrypted the feature is not
> included into initrd for the system. i got asked for the password by
> systemd, though.
> i tried forcing the luks uuid, and i also tried rd_NO_LUKS boot to see
> if it makes any difference. log of the last run is attached.
> i'm attaching a short info of my partition setup and dmesg from debug
> bootup. cryptsetup password was provided manually during boot, after a
> few seconds the big delay (evident in the log) happened.
> when i try booting, i get into text mode, get asked for maintenance
> root password and dropped into single mode shell. and that's a system
> that hasn't even ran the first install wizard to set up user accounts
> etc. nothing is changed in there.
> boot parameters used (if they are not visible in the log)
> systemd.log_level=debug
> systemd.log_target=kmsg
> rd_NO_LUKS
> video=1024x768 at 75
> root=UUID=ae028a28-be41-480b-ba16-6e648a3a3db3

Hmm, it seems dev-mapper-box\x2dfedoravar.device never shows up. Which
is an LVM device as it appears. Which makes me guess that this i
actually just an iteration of this bug:



Lennart Poettering - Red Hat, Inc.

More information about the systemd-devel mailing list