[systemd-devel] Can't get systemd-cryptsetup to automount my /home

Lennart Poettering lennart at poettering.net
Mon Sep 24 01:49:22 PDT 2012

On Sun, 23.09.12 13:33, Dennis Ek (dennis.a.ek at gmail.com) wrote:

> First of all: I'm running the latest Arch Linux (complete with the latest
> systemd and everything else) and I've encrypted both my / and /home.
> Now, the problem is that I can't get my /home to automount once I've
> mounted my /. My /etc/crypttab looks like this:
> home     /dev/sda3     /etc/homepwd
> I've created /etc/homepwd using
> echo password > /etc/homepwd
> And yes, I've entered the correct password.
> When I boot I get dropped to a rescue shell because I can't mount /home.
> Here's my journalctl output:
> systemd-cryptsetup[293]: Invalid passphrase.
> systemd-cryptsetup[293]: Set cipher aes, mode xts-plain, key size 512 bits
> for device /dev/sda3.
> systemd-cryptsetup[293]: Invalid passphrase.
> systemd-cryptsetup[293]: Too many attempts.
> I've tried playing with the permissions (even did a chmod 777), but I still
> can't get systemd-cryptsetup to realize that the file contains the correct
> password.
> So, what to do?

This is LUKS, right? It does work with "cryptsetup luksOpen"? 

Have you tried entering the password on the kbd, rather than via a file?


Lennart Poettering - Red Hat, Inc.

More information about the systemd-devel mailing list