[systemd-devel] Get rid of /etc/fstab

Colin Guthrie gmane at colin.guthr.ie
Mon Feb 4 04:14:52 PST 2013

'Twas brillig, and Andrey Borzenkov at 02/02/13 19:39 did gyre and gimble:
> В Sat, 2 Feb 2013 15:24:44 +0100
> Sébastien Luttringer <seblu at seblu.net> пишет:
>> Hello,
>> Looking forward to mount custom partitions I decided to use unit.mount
>> files to define my new fs. Everything works perfectly, so I tried to
>> do the same with all my mounted filesystems and removing /etc/fstab.
>> But unfortunatly, creating a -.mount file in
>> /etc/systemd/system/local-fs.target.wants not work as I expected. I
>> guess it's because generated file /run/systemd/generator/-.mount take
>> precedence.
>> Is there any way of removing old fstab to full unit configuration?
> One immediate question - do you use initrd? Does mkinitrd (or whatever
> is used by your distro) still correctly recognize root mount options in
> this case?

FWIW, dracut uses /proc/self/mountinfo to parse mounted filesystems
first, and only falls back to /etc/fstab parsing if that doesn't work
out too well.

Sadly dracut's < 25 and recent kernels mean that the
/proc/self/mountinfo parsing was a bit broken and thus fstab fallback is
probably the default in Fedora 19 (not double checked this personally as
I'm not a fedora user, just guessing it would be the case after
reporting the issue to Harald who fixed it properly in dracut 25 - No
idea about the Arch initrd situation tho')




Colin Guthrie

Day Job:
  Tribalogic Limited http://www.tribalogic.net/
Open Source:
  Mageia Contributor http://www.mageia.org/
  PulseAudio Hacker http://www.pulseaudio.org/
  Trac Hacker http://trac.edgewall.org/

More information about the systemd-devel mailing list