[systemd-devel] Systemd fails to give shell prompt on Linux 2.6.37

embedded linux embeddedlinuxforall at gmail.com
Tue Feb 12 03:41:48 PST 2013

Hi all,

I am working on bringing up Linux 2.6.37 on Ti DM8148 platform. I want use
systemd for faster boot up. I compiled systemd37 which supports linux
>=2.6.39 kernel version. As a first step I am trying to get serial shell
prompt, which is giving issues. With the documentation available in the
systemd site, I tried to enabled some of the systemd dependencies like
anotify, fanotify, devtmpfs, devtmpfs_mount. cgroups etc I still face the
same issue. I have attached the file for reference.
I also have tried with systemd28 version which supports from linux 2.6.30
or greater but no success.
On pandaboard omap4430 linux kernel 3.1.5 the rootfs with systemd37
initialzes well and provides me with shell prompt.

Can anybody tell me what kind of changes I need to make in kernel 2.6.37 in
order to support it with systemd?

Please help me to solve the issue.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/systemd-devel/attachments/20130212/2335caf1/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: boot_log_12_02_11:40_dm
Type: application/octet-stream
Size: 85176 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/systemd-devel/attachments/20130212/2335caf1/attachment-0001.obj>

More information about the systemd-devel mailing list