[systemd-devel] fstab Mounts Not Getting Waken Up

CACook at Quantum-Sci.com CACook at Quantum-Sci.com
Fri Jul 12 08:18:08 PDT 2013

CACook at Quantum-Sci.com:
> Dave Reisner:
>> On Thu, Jul 11, 2013 at 12:57:22PM -0700, CACook at Quantum-Sci.com wrote:
>>> I'd understood that if a mount is in fstab, that it should be
>>> re-established when the system wakes.  But that's not happening.
>>> Meaning two sshfs mounts as so:
>>> sshfs#carl at droog:/    /media/droog    fuse
>>> user,auto,_netdev,gid=6,umask=007,cache=no,ServerAliveInterval=15,allow_other,comment=sshfs
>>> 0 0
>>> Why would this be?
>> Your use of sshfs# as a FUSE type is wrong -- you must use fuse.sshfs as
>> the fstype instead.
>> I don't know if this in particular is the solution to the problem you're
>> seeing, but the source field is certainly wrong.
> Thanks, but it didn't work.
> Waking the machine from sleep, the drive is never mounted.

Also now the mount command fails.  Before it worked.
"/bin/sh: fuse.sshfs: command not found"

Believe me, my system has worked for years.  But with the transition to 
systemd, it will no longer mount on wake.

More information about the systemd-devel mailing list