[systemd-devel] [ANNOUNCE] systemd 199

Zbigniew Jędrzejewski-Szmek zbyszek at in.waw.pl
Wed Mar 27 07:31:29 PDT 2013

On Wed, Mar 27, 2013 at 12:01:41PM +0100, Philip Müller wrote:
> Here on this machine it still fails. It can also be an issue with
> this installation.
> I created a tarball out of git with followed commit as last one:
> 590888a0d0cb813714fa2a521e2ca711f75862fb <http://cgit.freedesktop.org/systemd/systemd/commit/?id=590888a0d0cb813714fa2a521e2ca711f75862fb>
> Still the same result:
> PASS: test-bus-signature
> ./build-aux/test-driver: Zeile 95: 20079 Speicherzugriffsfehler
> (Speicherabzug geschrieben) "$@" > $log_file 2>&1
> FAIL: test-bus-marshal
> Will test it on a different machine now.
Hi guys,

those are two or three different issues that you're seeing. The new
bus* stuff couldn't have caused failures in systemd-198, because it
wasn't there. I added SKIP to test-bus-chat (it fails unless
$DBUS_SESSION_BUS_ADDRESS is set, which often isn't.

test-unit-name might have been caused by %s problem, and if so, should
be fixed now.

test-bus-marshall is different, it looks like a real bug. You
can just run the test with
and it should give the same result as through the test harness.

When if fails, please compile with -g, and (a) if an assertion fails,
just post the full output from running the test program directly,
(b) a segafault happens, then run it under gdb. It is also
a good idea to run the failing test under valgrind.

One hurdle for running under valgrind or gdb is that when the
test programs are linked against shared systemd libraries, one
has to say something like:
   LD_LIBRARY_PATH=build/.libs valgrind --track-origins=yes build/.libs/test-unit-file


More information about the systemd-devel mailing list