[systemd-devel] root= ignored

Felix Miata mrmazda at earthlink.net
Thu Jan 29 01:20:44 PST 2015

Chris Murphy composed on 2015-01-28 23:51 (UTC-0700):

> Felix Miata wrote:

>> Chris Murphy composed on 2015-01-27 23:29 (UTC-0700):

>>> Felix Miata wrote:

>>>> Lennart Poettering composed on 2015-01-28 02:03 (UTC+0100):

>>>>> Hmm, Fedora doesn't obey root=? That sounds like a bug.

>>> I'm not sure what it means, Fedora doesn't obey root=. Since a long
>>> time it uses root=UUID= and this has worked for me.

>> All current distros whose bootloaders I've used include a root= in each of
>> their bootloader stanzas. AFAIK, root=UUID= is used in Fedora's Grub2
>> stanzas.

> That's true unless LVM is being used, which happens to be the default,
> in which case it's root=VG/LV.

I've used LVM on exactly one HD, since wiped, too many years ago to remember
when or which.

>> When Fedora is the source and clone, attempting boot of clone using default
>> initrd produces an emergency shell, unlike openSUSE.

> I'm unable to reproduce this problem on a BIOS system.

What you describe below looks little like the process I described.

> Old volume is
> Btrfs, new volumes is Btrfs (new volume UUID),

I didn't think any mention of filesystem type would be relevant in describing
my process, but all clones used as a Fedora / here have been either EXT3 or EXT4.

> and I just copy the

I wrote "clone" for a reason. I don't "just copy" files. I clone (logical,
root, autonomous) *partitions*, subsequently modifying only fstab, volume
label and UUID before attempting boot from it.

> files from old to new (I actually used btrfs send receive). I of
> course had to install a new bootloader with grub2-install, and create

The process I wrote was intended to make it clear that no bootloader that may
have been on a Fedora / partition was used for booting a Fedora clone as
adjusted to its new location. It's a process that was relatively simple and
reliable until humanly memorable cmdline root= parameters what worked
formerly began being disregarded by Fedora's boot process in apparent favor
of incorporating a root filesystem UUID subject to change during
backup/restore process in its initrd.

> Somehow dracut is
> baking in the EFI System partition UUID into the initramfs, instead of
> honoring the correct one that I put into fstab. As a result boot fails
> and will always fail until I rebuild the initramfs. So I'd definitely
> consider that a bug.

> https://bugzilla.redhat.com/show_bug.cgi?id=1187007

Noted, commented, CC'd.
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/

More information about the systemd-devel mailing list