[systemd-devel] Antw: Re: Antw: Re: Explain status "Loaded: not-found (Reason: No such file or directory)"

Ulrich Windl Ulrich.Windl at rz.uni-regensburg.de
Tue May 14 06:08:08 UTC 2019

>>> Lennart Poettering <lennart at poettering.net> schrieb am 13.05.2019 um 09:46
Nachricht <20190513074653.GC9036 at gardel-login>:
> On Mo, 13.05.19 07:48, Ulrich Windl (Ulrich.Windl at rz.uni‑regensburg.de)
>> >> I guess it's not a file named "Reason" that's missing. Despite of my
>> >> recommendation to create helpful error messages, can you explain what
>> > means?
>> >> Even after an strace I could not find out what is missing.
>> >>
>> >
>> > It means that unit definition file (iotwatch.target) was not found in
>> > any directory where systemd looks for it.
>> The confusing part is that something that cannot be found is "active" for
>> minutes ;‑)
> If you start a unit, then remove its unit file it remains started but
> the unit file cannot be found anymore. We try to make the best of it:
> leave the service running as well as possible, but will tell you the
> unit file is now absent.
> Of course, it's not a good idea to remove a unit file while a service
> is still running, but we cannot really stop you from doing so, this
> being UNIX and all...

Yes, that was a corner-case. I had updated the package via RPM, and it tried
to do it's best with a service: If running, it tried to restart it after
upgrade. In this case the generator was broken and effectively the unit file
wasn't updated but effectively removed... I didn't realize quickly what was
going on.


More information about the systemd-devel mailing list