[Bug 40380] Add tp_dbus_properties_mixin_emit_properties_changed
bugzilla-daemon at freedesktop.org
bugzilla-daemon at freedesktop.org
Fri Aug 26 12:25:30 CEST 2011
https://bugs.freedesktop.org/show_bug.cgi?id=40380
--- Comment #1 from Jonny Lamb <jonny.lamb at collabora.co.uk> 2011-08-26 03:25:29 PDT ---
Just a few bikeshedding points:
+ g_critical ("Couldn't fetch '%s' on interface '%s': %s",
+ property, iface, error->message);
I can't remember whether g_critical will include the function name in the log
message but perhaps have "Couldn't fetch property '%s..." to make it clearer?
+ g_return_val_if_fail (self != NULL, FALSE);
+ g_return_val_if_fail (G_IS_OBJECT (self), FALSE);
Not sure both of these are necessary?
- g_value_init (value, prop_info->type);
- iface_impl->getter (self, iface_info->dbus_interface,
- prop_info->name, value, prop_impl->getter_data);
+ if (value != NULL)
+ {
+ g_value_init (value, prop_info->type);
+ iface_impl->getter (self, iface_info->dbus_interface,
+ prop_info->name, value, prop_impl->getter_data);
+ }
Is this meant to be in the topmost commit?
+ tp_dbus_properties_mixin_emit_properties_changed (
+ GObject *object,
+ const gchar *interface_name,
+ const gchar * const *changed,
+ const gchar * const *invalidated)
Not sure about only passing the names of the changed properties. It's only a
bit crap if getting the property is expensive or time-consuming, but I guess
that never happens, right? Yeah, probably not, carry on.
+ WARNING ("u mad? %s", error->message);
soz.
--
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.
More information about the telepathy-bugs
mailing list