[Bug 33213] New: Rename _get_events() to get_entities()

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Mon Jan 17 21:01:33 CET 2011


           Summary: Rename _get_events() to get_entities()
           Product: Telepathy
           Version: git master
          Platform: Other
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: medium
         Component: logger
        AssignedTo: telepathy-bugs at lists.freedesktop.org
        ReportedBy: nicolas.dufresne at collabora.co.uk
         QAContact: telepathy-bugs at lists.freedesktop.org

In the logger API their exist a _get_events()/get_events_async() function that
returns a list of TplLogSearchHit which is partially initialized and
representing entities (contacts and rooms). Those function are use to list the
already logges buddies for an account.

To make this API more comprehensible I've renamed those function
_get_entities() and now return a GList of TplEntity.

Two last commit of this branch:

The first commit is just a cleanup/optimisation to avoid copying those lists
over and over.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the telepathy-bugs mailing list