[Bug 42546] Need TP_CONNECTION_FEATURE_CONTACT_LIST_PROPERTIES
bugzilla-daemon at freedesktop.org
bugzilla-daemon at freedesktop.org
Fri Nov 4 10:32:31 CET 2011
https://bugs.freedesktop.org/show_bug.cgi?id=42546
--- Comment #4 from Xavier Claessens <xclaesse at gmail.com> 2011-11-04 02:32:31 PDT ---
Comment on attachment 53103
--> https://bugs.freedesktop.org/attachment.cgi?id=53103
Add TP_CONNECTION_FEATURE_CONTACT_LIST_PROPERTIES
Review of attachment 53103:
--> (https://bugs.freedesktop.org/page.cgi?id=splinter.html&bug=42546&attachment=53103)
-----------------------------------------------------------------
::: telepathy-glib/connection-contact-list.c
@@ +423,4 @@
> return;
> }
>
> + /* Contacts will be prepared once the contact list has been fetched.
I would add that it refers to fetching contacts in CM from server,and not
client from CM.
@@ +644,5 @@
> * Expands to a call to a function that returns a #GQuark representing the
> * "contact-list" feature.
> *
> + * When this feature is prepared, the
> + * TP_CONNECTION_FEATURE_CONTACT_LIST_PROPERTIES has been prepared, so the
add a % before TP_CONNECTION_FEATURE_CONTACT_LIST_PROPERTIES
::: telepathy-glib/connection.c
@@ +1663,5 @@
> need_contact_list[0] = TP_IFACE_QUARK_CONNECTION_INTERFACE_CONTACT_LIST;
> need_contact_list[1] = TP_IFACE_QUARK_CONNECTION_INTERFACE_CONTACTS;
> features[FEAT_CONTACT_LIST].interfaces_needed = need_contact_list;
> + need_contact_list_props[0] = TP_CONNECTION_FEATURE_CONTACT_LIST_PROPERTIES;
> + features[FEAT_CONTACT_LIST].depends_on = need_contact_list_props;
Seems we use names need_foo to set interfaces_needed, but here you use
need_contact_list_props for depends_on. I would rename it to
depends_contact_list, meaning the features contact_list depends on. no?
--
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA Contact for the bug.
You are the assignee for the bug.
More information about the telepathy-bugs
mailing list