[Bug 44331] Gabble plugin API symbols should be factored out to a separate library
bugzilla-daemon at freedesktop.org
bugzilla-daemon at freedesktop.org
Fri Jan 6 18:01:12 CET 2012
https://bugs.freedesktop.org/show_bug.cgi?id=44331
--- Comment #15 from Olli Salli <ollisal at gmail.com> 2012-01-06 09:01:12 PST ---
Some clarifications:
(In reply to comment #12)
>
> GAsyncResult *gabble_plugin_create_sidecar_async(plugin, /* other params */,
> callback, user_data)
> {
> GabblePluginInterface *iface = GABBLE_PLUGIN_GET_INTERFACE (plugin);
> /* ... any applicable sanity checks with g_return_val_if_fail etc */
> return iface->create_sidecar_async(plugin, ..., callback, user_data);
> }
Which should replace current gabble_plugin_create_sidecar completely.
plugin-loader should start calling this one instead of it.
>
> GabbleSidecar *gabble_plugin_create_sidecar_finish(plugin, /* other params */)
> {
> GabblePluginInterface *iface = GABBLE_PLUGIN_GET_INTERFACE (plugin);
> /* ... any applicable sanity checks with g_return_val_if_fail etc */
> return iface->create_sidecar_finish(plugin, /* other params */);
> }
>
Should be modified from current gabble_plugin_create_sidecar_finish.
plugin-loader continues to call this function in the exactly same fashion as
before - it's just its implementation guts which have been scattered over each
plugin.
--
Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA Contact for the bug.
More information about the telepathy-bugs
mailing list