[Bug 49505] somewhat high-level API to add client channel filters
bugzilla-daemon at freedesktop.org
bugzilla-daemon at freedesktop.org
Fri Dec 27 06:26:53 PST 2013
https://bugs.freedesktop.org/show_bug.cgi?id=49505
--- Comment #3 from Guillaume Desmottes <guillaume.desmottes at collabora.co.uk> ---
Comment on attachment 61042
--> https://bugs.freedesktop.org/attachment.cgi?id=61042
proposed patch
Review of attachment 61042:
--> (https://bugs.freedesktop.org/page.cgi?id=splinter.html&bug=49505&attachment=61042)
-----------------------------------------------------------------
::: docs/reference/telepathy-glib-sections.txt
@@ +5629,5 @@
> <TITLE>base-client</TITLE>
> TpBaseClient
> TpBaseClientClass
> +tp_base_client_add_observer_filter_object
> +tp_base_client_take_observer_filter_object
agreed.
::: telepathy-glib/channel-filter.c
@@ +331,5 @@
> + * been passed to a #TpBaseClient.
> + */
> +void
> +tp_channel_filter_require_channel_type (TpChannelFilter *self,
> + const gchar *channel_type)
Wouldn't it be enough to drop this from the public API and enforce users to
create the specialised version of _new_*()? At the moment we could so something
like:
f = tp_channel_filter_new_for_text_chatrooms ();
tp_channel_filter_require_channel_type (f, TP_IFACE_CHANNEL_TYPE_CALL);
which is pretty weird.
If we go this way, tp_channel_filter_new () could be renamed new_for_all() or
something.
Another option could be to return_if_fail () if there is already a channel type
on the filter.
--
You are receiving this mail because:
You are the QA Contact for the bug.
More information about the telepathy-bugs
mailing list