[Telepathy-commits] [telepathy-gabble/master] rewrite a comment for clarification

Guillaume Desmottes guillaume.desmottes at collabora.co.uk
Fri Sep 26 04:30:49 PDT 2008


---
 src/conn-olpc.c |    6 ++++--
 1 files changed, 4 insertions(+), 2 deletions(-)

diff --git a/src/conn-olpc.c b/src/conn-olpc.c
index 1def315..f87b93c 100644
--- a/src/conn-olpc.c
+++ b/src/conn-olpc.c
@@ -1382,11 +1382,13 @@ extract_current_activity (GabbleConnection *conn,
   if (node == NULL)
     return NULL;
 
+  /* For some weird reasons, the PEP protocol use "type" for the activity ID.
+   * We can't change that without breaking compatibility but if there is no
+   * "type" attribute then we can use the "id" one.
+   * The Gadget protocol use "id" instead of "type". */
   id = lm_message_node_get_attribute (node, "type");
   if (id == NULL)
     {
-      /* This attribute should be called "id" and not "type". Gadget uses the
-       * right name. */
       id = lm_message_node_get_attribute (node, "id");
     }
 
-- 
1.5.6.5




More information about the Telepathy-commits mailing list