[Telepathy] RFC: tighten definition of CM name and protocol name
sjoerd at luon.net
Tue Nov 20 03:30:17 PST 2007
On Tue, Nov 20, 2007 at 10:57:14AM +0000, Simon McVittie wrote:
> I propose that we tighten the definition of these strings so they must contain
> only letters, digits and the ASCII hyphen/minus sign (which must be replaced
> with an underscore by the libraries when used in an object path or bus
I prefer this option. Renaming the protocol in Salut again would be painfull.
The first change from salut to local-xmpp was bad enough...
> Alternatively, we could restrict to letters, digits and underscores,
> with "-" replaced by "_" by the libraries for backwards-compatibility.
> This would require us to rename "local-xmpp" to "local_xmpp", though.
Apart from that. I think local_xmpp looks stupid :)
> At the moment telepathy-glib escapes these strings using
> tp_escape_as_identifier (basically URI-escaping with _ instead of % and
> a smaller allowed set), so local-xmpp shows up in the object paths and
> bus names as local_2dxmpp, which looks a bit stupid, and means we can't
> meaningfully search for connections that come from a particular CM or
So little time, so little to do.
-- Oscar Levant
More information about the Telepathy