[uim-commit] r2370 - branches/r5rs/sigscheme

yamaken at freedesktop.org yamaken at freedesktop.org
Sun Dec 4 14:38:48 PST 2005


Author: yamaken
Date: 2005-12-04 14:38:45 -0800 (Sun, 04 Dec 2005)
New Revision: 2370

Modified:
   branches/r5rs/sigscheme/sigschemetype-compact.h
Log:
* sigscheme/sigschemetype-compact.h
  - (SCM_DEREF): Remove the alternative for SCM_DEBUG since the
    non-debug version is already returns rvalue


Modified: branches/r5rs/sigscheme/sigschemetype-compact.h
===================================================================
--- branches/r5rs/sigscheme/sigschemetype-compact.h	2005-12-04 22:35:19 UTC (rev 2369)
+++ branches/r5rs/sigscheme/sigschemetype-compact.h	2005-12-04 22:38:45 UTC (rev 2370)
@@ -730,11 +730,7 @@
 #define SCM_REF_OFF_HEAP(obj) (&(obj))
 
 /* SCM_DEREF(ref) is not permitted to be used as lvalue */
-#if SCM_DEBUG
-#define SCM_DEREF(ref)    ((ScmObj)(SCM_CAST_UINT(*(ref) + 0) & ~SCM_GCBIT_MASK))
-#else /* SCM_DEBUG */
 #define SCM_DEREF(ref)    ((ScmObj)(SCM_CAST_UINT(*(ref)) & ~SCM_GCBIT_MASK))
-#endif /* SCM_DEBUG */
 
 /* RFC: Is there a better name? */
 #define SCM_SET(ref, obj) (*(ref) = (ScmObj)((SCM_CAST_UINT(*(ref)) & SCM_GCBIT_MASK) | SCM_CAST_UINT(obj)))



More information about the uim-commit mailing list