[uim-commit] r2503 - branches/r5rs/sigscheme

kzk at freedesktop.org kzk at freedesktop.org
Fri Dec 9 17:15:30 PST 2005


Author: kzk
Date: 2005-12-09 17:15:25 -0800 (Fri, 09 Dec 2005)
New Revision: 2503

Modified:
   branches/r5rs/sigscheme/sigschemetype-compact.h
Log:
* sigscheme/sigschemetype-compact.h
  - (SCM_SET): add masking to SCM_CAST_UINT(obj)


Modified: branches/r5rs/sigscheme/sigschemetype-compact.h
===================================================================
--- branches/r5rs/sigscheme/sigschemetype-compact.h	2005-12-09 23:59:19 UTC (rev 2502)
+++ branches/r5rs/sigscheme/sigschemetype-compact.h	2005-12-10 01:15:25 UTC (rev 2503)
@@ -772,7 +772,7 @@
 #define SCM_DEREF(ref)    ((ScmObj)(SCM_CAST_UINT(*(ref)) & ~SCM_GCBIT_MASK))
 
 /* RFC: Is there a better name? */
-#define SCM_SET(ref, obj) (*(ref) = (ScmObj)((SCM_CAST_UINT(*(ref)) & SCM_GCBIT_MASK) | SCM_CAST_UINT(obj)))
+#define SCM_SET(ref, obj) (*(ref) = (ScmObj)(SCM_GC_BIT(*(ref)) | (SCM_CAST_UINT(obj) & ~SCM_GCBIT_MASK)))
 
 /*============================================================================
   Compatibility for non-compact code



More information about the uim-commit mailing list