[uim-commit] r2100 - branches/r5rs/sigscheme
kzk at freedesktop.org
kzk at freedesktop.org
Tue Nov 8 14:26:42 PST 2005
Author: kzk
Date: 2005-11-08 14:26:36 -0800 (Tue, 08 Nov 2005)
New Revision: 2100
Modified:
branches/r5rs/sigscheme/sigscheme.h
Log:
* (SCM_REINTERPRET_CAST): change to use temporary (int) casting.
The code before this commit has the problem around
functpointer <=> normal pointer casting.
Notice: I don't know this is the proper solution.
Modified: branches/r5rs/sigscheme/sigscheme.h
===================================================================
--- branches/r5rs/sigscheme/sigscheme.h 2005-11-08 20:17:07 UTC (rev 2099)
+++ branches/r5rs/sigscheme/sigscheme.h 2005-11-08 22:26:36 UTC (rev 2100)
@@ -63,7 +63,7 @@
#define SCM_NORETURN
#endif /* __GNUC__ */
-#define SCM_REINTERPRET_CAST(type, obj) (*(type *)&(obj))
+#define SCM_REINTERPRET_CAST(type, obj) ((type)(int)(obj))
/* RFC: better names for the debug printing */
#if SCM_DEBUG
More information about the uim-commit
mailing list