[Uim] Re: Suggestion: Renaming new API functions
tkng at xem.jp
Thu Oct 7 00:26:51 EEST 2004
On Fri, 01 Oct 2004 17:48:52 +0900
YamaKen <yamaken at bp.iij4u.or.jp> wrote:
> > > So I suggest an accurate name uim_get_im_name_of_context().
> > Because uim's input context has plural input methods (so of course
> > plural input method names), I opposite this function name. Anyway, I
> > need your blow-by-blow opinion.
> In your view, an input context HAS an input method as slave. So
> each input context also has the concept 'current input context'.
Yes, but it's not my view. A uim_context keeps a list of available input
methods as a struct member actually.
> But in natural view, an input context BELONGS TO only one input
> method. So I suggest the name uim_im_name_of_context() to
> conform to this model. It simply returns its only one input
> method name as an attribute of the input context.
I want to distinguish these two models as 1-n model and 1-1 model.
I agree that people will feel 1-1 model is more natural than 1-n model.
To be honest, I was also confused this concept before. But as identified
above, uim_context has a list of available input methods actually and
it's refrected to the API. See the function uim_get_nr_im.
Uim already employed 1-n model, so introducing 1-1 model will cause API
confusion. I think such change should be done after 1.0.0, because it
concerns developers only, there's no direct benefit to users.
More information about the uim