[waffle] [PATCH 5/8] cmake: reformat/update install targets

Chad Versace chad.versace at intel.com
Fri May 30 17:43:49 PDT 2014


On Sat, May 24, 2014 at 11:51:32PM +0100, Emil Velikov wrote:
> Cleanup the formatting and add component for each build target.
> The latter will allow us to use CPack to create a component
> based installer for Windows.

I've never used CPack, so my review here is a little uninformed.
I have one small request.


> diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
> index b89fde3..a2d46e6 100644
> --- a/doc/CMakeLists.txt
> +++ b/doc/CMakeLists.txt
> @@ -1,7 +1,14 @@
> -install(FILES "${CMAKE_SOURCE_DIR}/README.txt"
> -              "${CMAKE_SOURCE_DIR}/LICENSE.txt"
> -        DESTINATION "${CMAKE_INSTALL_DOCDIR}")
> +install(
> +    FILES
> +        "${CMAKE_SOURCE_DIR}/README.txt"
> +        "${CMAKE_SOURCE_DIR}/LICENSE.txt"
> +    DESTINATION "${CMAKE_INSTALL_DOCDIR}"
> +    COMPONENT coredocs
> +    )



> diff --git a/man/html.cmake b/man/html.cmake
> index ea55600..efe3887 100644
> --- a/man/html.cmake
> +++ b/man/html.cmake
> @@ -92,5 +92,8 @@ add_custom_target(html
>      DEPENDS ${html_outputs}
>      )
>  
> -install(DIRECTORY ${html_out_dir}
> -        DESTINATION ${CMAKE_INSTALL_DOCDIR}/html)
> +install(
> +    DIRECTORY ${html_out_dir}
> +    DESTINATION ${CMAKE_INSTALL_DOCDIR}/html
> +    COMPONENT docs
> +    )


I find the name 'docs' confusing, relative to 'coredocs',  because
I usually interpreet 'foo' as a superset of '${qualifier}_foo'. I'd like
to rename it to 'htmldocs', which is a more accurate name anyway. Will
that confuse CPack or the Windows installer?


More information about the waffle mailing list