[waffle] [PATCH 00/12] JSON and platform-specific wflinfo

Frank Henigman fjhenigman at google.com
Wed Jan 6 16:12:34 PST 2016


On Wed, Jan 6, 2016 at 6:43 PM, Dylan Baker <baker.dylan.c at gmail.com> wrote:
> Okay, I have some comments:
>
> When I run wflinfo -p gbm -a gl -f json | jsontidy (a small python script I
> have that formats JSON to be human readable)
> I get this:
> {
>     "generic": {
>         "waffle": {
>             "api": "WAFFLE_CONTEXT_OPENGL",
>             "platform": "WAFFLE_PLATFORM_GBM"
>         },
>         "extensions": [
>             "GL_3DFX_texture_compression_FXT1",
> ... (truncated for readability)
>             "GL_SUN_multi_draw_arrays"
>         ],
>         "opengl": {
>             "renderer": "Mesa DRI Intel(R) Haswell Mobile ",
>             "version": "3.0 Mesa 11.1.0",
>             "vendor": "Intel Open Source Technology Center"
>         },
>         "shading_language_version": "1.30"
>     }
> }
>
> I think the shading_language_version and extensions belong in the opengl
> dictionary.

I didn't give much thought at the time to structure nor key names.
Figured there
would some debate in any case.  (-:
Makes sense to put gl extensions in the "opengl" block.
How about a glsl block?  Seems like there might be other stuff in it some day,
and adds consistency to the use of "version" i.e.
  "glsl" : {
    "version" : "1.30"
  }
I'm not as sure about putting it inside the opengl block, but not
fussy about it either.
If there's no dissent I'll do as you suggest.

> Other than that the output seems reasonable and quite usable for my
> purposes.

Once again sorry for not sending mine out sooner.  If none of your patch makes
it in, hopefully it had some value to you as an exercise.


More information about the waffle mailing list