[Wayland-bugs] [Bug 729215] Please implement Wayland subsurfaces
gtk+ (bugzilla.gnome.org)
bugzilla at gnome.org
Mon Aug 25 11:26:00 PDT 2014
https://bugzilla.gnome.org/show_bug.cgi?id=729215
gtk+ | Backend: Wayland | 3.13.x
Jasper St. Pierre <jstpierre> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #284192|none |reviewed
status| |
--- Comment #12 from Jasper St. Pierre <jstpierre at mecheye.net> 2014-08-25 18:25:55 UTC ---
Review of attachment 284192:
--> (https://bugzilla.gnome.org/review?bug=729215&attachment=284192)
::: gdk/wayland/gdkwindow-wayland.c
@@ +1167,3 @@
}
+ g_clear_pointer (&impl->subsurface, wl_subsurface_destroy);
I don't like doing protocol operations in g_clear_pointer. Can you write this
as an explicit statement?
@@ +1254,3 @@
+
+ if (impl->subsurface)
+ wl_subsurface_set_position (impl->subsurface, x, y);
Can you move this into the TOPLEVEL check below for clarity? We shouldn't ever
hit this on a toplevel.
@@ +1554,3 @@
gdk_wayland_window_sync_parent (window);
+
+ g_clear_pointer (&impl->subsurface, wl_subsurface_destroy);
Same comment as above.
--
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
More information about the Wayland-bugs
mailing list