[Wayland-bugs] [Bug 752258] Epiphany displays incorrect name in gnome-shell app menu

gtk+ (GNOME Bugzilla) bugzilla at gnome.org
Thu Jul 16 17:48:42 PDT 2015


https://bugzilla.gnome.org/show_bug.cgi?id=752258

--- Comment #24 from Jonas Ådahl <jadahl at gmail.com> ---
(In reply to Jasper St. Pierre from comment #23)
> (In reply to Jonas Ådahl from comment #20)
> > So, according to Jasper in comment 15 "prgname" should be (or is completely
> > valid to be) the name of the binary, and according to Michael in comment 16
> > "prgname" should always be the basename of the .desktop file. For the
> > org.gnome.gedit.desktop case, *should* the prgname be "gedit" or
> > "org.gnome.gedit"?
> > 
> > If it should be "gedit" then we cannot use prgname to set the xdg_surface
> > app_id since it should mean that for D-Bus activatable applications always
> > set the wrong ID. Using the GtkApplication ID isn't very good either, since
> > it'd be wrong for all non-D-Bus-activatable applications, but at least it
> > isn't incorrect forever.
> 
> For gedit, xdg_surface.set_app_id should be called with "gedit", and
> gtk_surface.set_gtk_application_id should be called with "org.gnome.gedit".

That'd go against any version of "set_app_id" I've seen. The .desktop file of
gedit is "org.gnome.gedit.desktop", gedit is a D-Bus activatable applicatoin.
According to xdg_surface.set_app_id it should definitely not be "gedit".

If you think xdg_surface.set_app_id is wrong and should be some "binary name"
or similar, unrelated to .desktop file names and D-Bus names, then we'd need to
change the spec (and probably not call it anything with "ID".

(In reply to Florian Müllner from comment #22)
> (In reply to Michael Catanzaro from comment #21)
> > It should be "org.gnome.gedit" based on our current guidance at
> > https://wiki.gnome.org/Projects/GnomeShell/ApplicationBased
> 
> For dbus-activatable apps using GApplication (like gedit), it doesn't matter
> - we won't use the WM_CLASS at all in that case, as matching by
> _GTK_APPLICATION_ID already turns up the .desktop file.

The question is rather, how do we get a valid name to pass to
xdg_surface.set_app_id, which id should be the base name of the .desktop file.
Can we force GtkApplication apps to set the prgname to this and put that use
case in the API docs?

-- 
You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/wayland-bugs/attachments/20150717/11f5f33e/attachment-0001.html>


More information about the wayland-bugs mailing list