[Wayland-bugs] [Bug 744932] Wrong (ultra tiny/small) cursor size on HiDPI screen

mutter (GNOME Bugzilla) bugzilla at gnome.org
Wed Sep 9 18:13:02 PDT 2015


https://bugzilla.gnome.org/show_bug.cgi?id=744932

--- Comment #138 from Jonas Ã…dahl <jadahl at gmail.com> ---
(In reply to Owen Taylor from comment #132)
> Review of attachment 310996 [details] [review]:
> 
> @@ +993,3 @@
> +  MetaWaylandSurfaceRoleCursor *cursor_role =
> +    META_WAYLAND_SURFACE_ROLE_CURSOR (surface->role);
> +  MetaCursorSprite *displayed_cursor_sprite;
> 
> No change needed, but I wanted to mention that there is no line length limit
> in Mutter source code, and the goal of introducing line breaks is to
> maximize readability.

FWIW I more or less always use vertical split editor buffers, so long lines are
usually unreadable in my setup.

In reply to Owen Taylor from comment #136)
> Review of attachment 310995 [details] [review]:
> 
> It looks like in this version, you are no longer reusing buffers, but always
> allocating new buffers. I wanted to note (perhaps for a future improvement)
> that if buffers are not being reused, then this can be simplified
> considerably, and the handling of avoiding messing with buffers that are
> being scanned out could be handled in done in the *renderer* rather than in
> the sprite, with a single BO attached to the sprite.

Yea, I dropped that part, but didn't do any more major changes because its not
the right time to redesign things just right now. I agree with you here anyhow.

> ::: src/backends/native/meta-cursor-renderer-native.c
> @@ +508,3 @@
> +   * should unset, or succeed, which will set new buffer.
> +   */
> +  destroy_pending_cursor_sprite_gbm_bo (cursor_sprite);
> 
> Putting the private into an "invalid state", then having a later call to fix
> it up seems fiddly and fragile - why isn't the destroy part of the
> set_pending_cursor_sprite_gbm_bo[_failed]()? 
> 
> You could possibly just call set_pending_cursor_sprite_gbm_bo_failed() up
> front rather than in each failure path - similar to how you set the state to
> FAILED at initialization.

Thought about doing it up front, but "FAILED" didn't make sense as a
intermediate state. INVALIDATED would maybe make more sense. I'll go with that.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/wayland-bugs/attachments/20150910/2d18b93f/attachment.html>


More information about the wayland-bugs mailing list