<html>
<head>
<base href="https://bugzilla.gnome.org/" />
</head>
<body><span class="vcard"><a href="page.cgi?id=describeuser.html&login=jadahl%40gmail.com" title="Jonas Ådahl <jadahl@gmail.com>"> <span class="fn">Jonas Ådahl</span></a>
</span> changed
<a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement primary selection protocol"
href="https://bugzilla.gnome.org/show_bug.cgi?id=762561">bug 762561</a>
<br>
<table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>What</th>
<th>Removed</th>
<th>Added</th>
</tr>
<tr>
<td style="text-align:right;">Attachment #322174 status</td>
<td>none
</td>
<td>reviewed
</td>
</tr></table>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement primary selection protocol"
href="https://bugzilla.gnome.org/show_bug.cgi?id=762561#c5">Comment # 5</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement primary selection protocol"
href="https://bugzilla.gnome.org/show_bug.cgi?id=762561">bug 762561</a>
from <span class="vcard"><a href="page.cgi?id=describeuser.html&login=jadahl%40gmail.com" title="Jonas Ådahl <jadahl@gmail.com>"> <span class="fn">Jonas Ådahl</span></a>
</span></b>
<pre>Review of <span class=""><a href="attachment.cgi?id=322174&action=diff" name="attach_322174" title="wayland: Make the function to get the last serial a seat one">attachment 322174</a> <a href="attachment.cgi?id=322174&action=edit" title="wayland: Make the function to get the last serial a seat one">[details]</a></span> <a href='review?bug=762561&attachment=322174'>[review]</a>:
::: gdk/wayland/gdkdevice-wayland.c
@@ +3031,3 @@
+ wayland_seat = GDK_WAYLAND_SEAT (seat);
+ g_hash_table_iter_init (&iter, wayland_seat->touches);
This is not related to this patch, but I fail to see when touches are added to
seat->touches. I do see when they are added to some GdkWaylandDeviceData
though. If seat->touches is always empty we'd regress here anyhow.
::: gdk/wayland/gdkwindow-wayland.c
@@ +1337,3 @@
parent_impl->display_server.wl_surface,
seat,
+
_gdk_wayland_seat_get_last_implicit_grab_serial (gdk_seat, NULL),
Completely only an opinion, but I think it'd be easier to read to fetch this
value before, and pass it as a variable "grab_serial" or something.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are on the CC list for the bug.</li>
</ul>
</body>
</html>