<html>
<head>
<base href="https://bugzilla.gnome.org/" />
</head>
<body><span class="vcard"><a href="page.cgi?id=describeuser.html&login=ebassi%40gmail.com" title="Emmanuele Bassi (:ebassi) <ebassi@gmail.com>"> <span class="fn">Emmanuele Bassi (:ebassi)</span></a>
</span> changed
<a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement KDE's server-decoration protocol"
href="https://bugzilla.gnome.org/show_bug.cgi?id=781909">bug 781909</a>
<br>
<table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>What</th>
<th>Removed</th>
<th>Added</th>
</tr>
<tr>
<td style="text-align:right;">Attachment #350696 status</td>
<td>none
</td>
<td>reviewed
</td>
</tr></table>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement KDE's server-decoration protocol"
href="https://bugzilla.gnome.org/show_bug.cgi?id=781909#c2">Comment # 2</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Implement KDE's server-decoration protocol"
href="https://bugzilla.gnome.org/show_bug.cgi?id=781909">bug 781909</a>
from <span class="vcard"><a href="page.cgi?id=describeuser.html&login=ebassi%40gmail.com" title="Emmanuele Bassi (:ebassi) <ebassi@gmail.com>"> <span class="fn">Emmanuele Bassi (:ebassi)</span></a>
</span></b>
<pre>Review of <span class=""><a href="attachment.cgi?id=350696&action=diff" name="attach_350696" title="Implements the KDE server-side decorations protocol">attachment 350696</a> <a href="attachment.cgi?id=350696&action=edit" title="Implements the KDE server-side decorations protocol">[details]</a></span> <a href='review?bug=781909&attachment=350696'>[review]</a>:
Hi; thanks for the patch — and I apologise for taking this long to get a
review.
In general, this looks okay to me, and fits in with the GTK approach.
::: gdk/wayland/gdkdisplay-wayland.c
@@ +336,3 @@
static void
+server_decoration_manager_default_mode(void *data,
+ struct org_kde_kwin_server_decoration_manager *manager,
Coding style:
1. missing space between function name and open parenthesis
2. the argument types should be aligned
@@ +340,3 @@
+{
+ GdkWaylandDisplay *display_wayland = data;
+ g_warning("Compositor prefers decoration mode %d", mode);
This should be a g_debug(), and it would be nice to translate the mode from
integer to string, according to the protocol.
@@ +479,3 @@
+ wl_registry_bind (display_wayland->wl_registry, id,
+ &org_kde_kwin_server_decoration_manager_interface,
1);
+
org_kde_kwin_server_decoration_manager_add_listener(display_wayland->server_decoration_manager,
Coding style: missing space between function name and open parenthesis.
::: gdk/wayland/gdkwaylanddisplay.h
@@ +59,3 @@
+gboolean
+gdk_wayland_display_prefers_ssd (GdkDisplay
*display);
Coding style: the name of the function should be on the same line as the return
type.
::: gdk/wayland/gdkwaylandwindow.h
@@ +82,3 @@
char
*parent_handle_str);
+void gdk_wayland_window_enable_csd (GdkWindow
*window);
I think this is a bit of a misnomer; we're not really enabling CSD per se — we
are telling the compositor that we are using client-side decorations.
I don't have a better name to propose, though.</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are on the CC list for the bug.</li>
</ul>
</body>
</html>