<html>
<head>
<base href="https://bugzilla.gnome.org/" />
</head>
<body><span class="vcard"><a href="page.cgi?id=describeuser.html&login=jadahl%40gmail.com" title="Jonas Ådahl <jadahl@gmail.com>"> <span class="fn">Jonas Ådahl</span></a>
</span> changed
<a class="bz_bug_link
bz_status_NEW "
title="NEW - Restoring maximized window state in Wayland results in tiny window"
href="https://bugzilla.gnome.org/show_bug.cgi?id=783901">bug 783901</a>
<br>
<table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>What</th>
<th>Removed</th>
<th>Added</th>
</tr>
<tr>
<td style="text-align:right;">Attachment #354146 status</td>
<td>none
</td>
<td>reviewed
</td>
</tr></table>
<p>
<div>
<b><a class="bz_bug_link
bz_status_NEW "
title="NEW - Restoring maximized window state in Wayland results in tiny window"
href="https://bugzilla.gnome.org/show_bug.cgi?id=783901#c29">Comment # 29</a>
on <a class="bz_bug_link
bz_status_NEW "
title="NEW - Restoring maximized window state in Wayland results in tiny window"
href="https://bugzilla.gnome.org/show_bug.cgi?id=783901">bug 783901</a>
from <span class="vcard"><a href="page.cgi?id=describeuser.html&login=jadahl%40gmail.com" title="Jonas Ådahl <jadahl@gmail.com>"> <span class="fn">Jonas Ådahl</span></a>
</span></b>
<pre>Review of <span class=""><a href="attachment.cgi?id=354146&action=diff" name="attach_354146" title="[PATCH 1/3] core: Add new wayland unmaximize flag">attachment 354146</a> <a href="attachment.cgi?id=354146&action=edit" title="[PATCH 1/3] core: Add new wayland unmaximize flag">[details]</a></span> <a href='review?bug=783901&attachment=354146'>[review]</a>:
::: src/core/window-private.h
@@ +80,3 @@
+ META_MOVE_RESIZE_WAYLAND_RESIZE = 1 << 4,
+ META_MOVE_RESIZE_STATE_CHANGED = 1 << 5,
+ META_MOVE_RESIZE_WAYLAND_UNMAXIMIZE = 1 << 6,
Could take the opportunity and unalign these, so we don't have to relalign next
time we add anything
::: src/core/window.c
@@ +3093,3 @@
META_MOVE_RESIZE_RESIZE_ACTION |
+ META_MOVE_RESIZE_STATE_CHANGED |
+ META_MOVE_RESIZE_WAYLAND_UNMAXIMIZE),
This doesn't look Wayland related, why not just call it
META_MOVE_RESIZE_UNMAXIMIZE?</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are on the CC list for the bug.</li>
</ul>
</body>
</html>