Not able to run wayland or wayland-demos in ubuntu

PRASANNA KUMAR prasanna_tsm_kumar at
Sat Apr 7 20:20:52 PDT 2012


If I run "wayland-compositor" I am getting the following error:

Mesa 7.11 implementation error: Incomplete OpenGL ES 2.0 support.
Please report at
shader info: �J�
shader info: �J�
link info: error: program lacks a vertex shader

failed to create compositor.

If I run any demo applications using "waylan-run gears" it says:
XDG_RUNTIME_DIR not set, falling back to .
failed to create display: No such file or directory
failed to create display: No such file or directory

What is the problem in my setup? I am running ubuntu 11.10. I have compiled Mesa 7.11 from source. Should I modify any flags while compiling?

I am using Intel 82945G/GZ Integrated Graphics Controller - i915 driver. KMS/DRI is available. The card does not support full OpenGL 2.0. I have attached the glxinfo with this mail (will it provide some useful information?).

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: glxinfo
Type: application/octet-stream
Size: 11642 bytes
Desc: not available
URL: <>

More information about the wayland-devel mailing list