GTK Ubuntu Precise packaging success

Rune Kjær Svendsen runesvend at
Thu Apr 19 09:02:29 PDT 2012

I'm trying it out on a live CD now that I've created with the script I'm
attaching to this message.
For some reason it's not working. Here are the messages I'm getting running
the programs you've listed in the order you listed them:
weston says the following:

All of the programs appear quickly only to crash right after.

I think I followed your instructions exactly. First I export the following
environment variable in one terminal, and run weston:
export XDG_RUNTIME_DIR=/tmp

then in another I export the following:
export XDG_RUNTIME_DIR=/tmp
export GDK_BACKEND=wayland

and run whichever program I want.

This is in my .bashrc:

Not sure if it's related to the live CD somehow. It worked when I just
fired up a clean live CD, installed your GTK backend and ran the stuff from

2012/4/18 <darxus at>

> On 04/18, Rune Kjær Svendsen wrote:
> >    Pretty cool Darxus! Works as well on a Precise live CD (USB stick). I
> only
> Nice, thanks.
> >    had to replace the second "apt-get upgrade" with "apt-get
> dist-upgrade".
> Yeah, sorry about that, I already fixed that in the directions in the PPA.
> >    Then I went to a VT and restarted lightdm with:
> >    sudo service lightdm restart
> >    and ran:
> >    unity --reset
> >    on the same VT
> Cool.
> >    Back at VT 7 unity had restarted and weston ran fine (got some errors
> like
> >    "Internal error:�� Could not resolve keysym SunProps/SunFront/SunOpen"
> That's normal, I don't know what it is.
> >    though). The programs you mentioned all ran fine initially, but it all
> >    went downhill when I tried running weston from a VT to get it in full
> >    screen mode (yeah yeah, total hubris, I know). Now some programs
> start,
> >    but crash when I mouse over them, and the more complex programs
> (like...
> >    anything but calculator) don't start at all.
> Weird.  Only thing I can think of that *might* be related is having
> another instance of weston running.  I've seen some weird things happen
> related to that.  Try running "killall weston" and then trying again.
> >    Would there be a way to get weston to run from a VT? That is, in full
> >    screen mode?
> Yup.  weston needs to be suid root (or run from weston-launcher, which
> isn't included in v0.85).  So:
> sudo chown root ~/install/bin/weston
> sudo chmod +s ~/install/bin/weston
> Then run weston from your VT.
> --
> "Every man, woman and child on the face of this earth is at the mercy
> of chaos." - a maxwell smart movie
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/x-sh
Size: 4276 bytes
Desc: not available
URL: <>

More information about the wayland-devel mailing list