[PATCH 0/8] Fixes for fullscreen with "driver" method
Kristian Høgsberg
hoegsberg at gmail.com
Fri Dec 14 08:42:03 PST 2012
On Fri, Dec 14, 2012 at 01:37:22PM -0200, Ander Conselvan de Oliveira wrote:
> From: Ander Conselvan de Oliveira <ander.conselvan.de.oliveira at intel.com>
>
> There were a few bugs with this feature. The first two patches make
> transformed optionally use that fullscreen method. The next four
> patches fixes bugs that prevented that for working and the last two
> patches refactors code to reduce code duplication in that path.
>
> Thanks,
> Ander
Nice, good patches. In particular, I like removing the drmSetCrtc
form mode switch and relying on the regular mode set path. I don't
think we did the on-demand modeset when the switch_mode code was
merged so it wasn't possible at the time. Anyway, all committed, thanks.
Kristian
> Ander Conselvan de Oliveira (8):
> window: Allow clients to choose the fullscreen method
> transformed: Add options for using debuging driver fullscreen method
> compositor: Update output state after mode switch
> compositor: Don't let pointers get outside of an output on mode
> switch
> compositor-drm: Fix a return value check in drm_output_switch_mode()
> compositor-drm: Don't do a mode set on drm_output_switch_mode()
> compositor-drm: Move output gl state initialization to own function
> compositor-drm: Reduce code duplication on drm_output_switch_mode()
>
> clients/transformed.c | 57 ++++++++++++++++++-
> clients/window.c | 11 +++-
> clients/window.h | 3 +
> src/compositor-drm.c | 147 ++++++++++++++++++++-----------------------------
> src/compositor.c | 54 +++++++++++++++++-
> 5 files changed, 179 insertions(+), 93 deletions(-)
>
> --
> 1.7.9.5
>
> _______________________________________________
> wayland-devel mailing list
> wayland-devel at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/wayland-devel
More information about the wayland-devel
mailing list