Build problems on Ubuntu Natty (11.04)

Pekka Paalanen ppaalanen at
Tue Mar 13 02:36:58 PDT 2012

On Tue, 13 Mar 2012 02:06:29 -0700
Bill Spitzak <spitzak at> wrote:

> I am attempting to build the development version of Wayland, but have 
> not gotten a working version. I hope perhaps the problem is easy to 
> figure out.
> The system is Ubuntu Natty: Linux lulu 2.6.38-13-generic #56-Ubuntu SMP 
> Tue Feb 14 12:40:40 UTC 2012 i686 i686 i386 GNU/Linux
> It is a really old box, /proc/cpuinfo says it has 2 Intel(R) Pentium(R) 
> 4 CPU 2.60GHz
> Card is also a really old Nvidia card: a Quadro FX1100 AGP 8X. The 
> Nvidia driver it needs is 173.14.30.
> I built wayland from git using the following script:
> This worked without errors, leaving everything in ~/install. I had 
> previously tried several variations but this is the first that worked, I 
> was pretty careful to delete all remnants of the old versions.
> During building the nouveau driver was active, if that makes any difference.
> I enabled the nouveau driver by the following steps:
>   aptitude install xserver-xorg-video-nouveau
>   aptitude install libgl1-mesa-dri-experimental
>   edit /etc/X11/xorg.conf and change "nvidia" to "nouveau"
>   reboot the machine, not just restart X
> (note that the suggestion of using System/Administration/Additional 
> Drivers did not work, it failed to update xorg.conf, possibly because it 
> mistakenly thought the nvidia driver was "activated but not in use". It 
> is also a lot faster to just edit xorg.conf back-and-forth)
> Trying to run weston from an X terminal produces the following crash:
> % export LD_LIBRARY_PATH=~/install/lib
> % ~/install/bin/weston
> nvfx_screen_get_param:103 -  Warning: unknown PIPE_CAP 57
> Mesa 8.1-devel implementation error: Incomplete OpenGL ES 2.0 support.
> Please report at
> unlinking stale lock file /tmp/.X1-lock
> xserver listening on display :1
> couldn't open /home/spitzak/.config/weston-desktop-shell.ini
> XDG_RUNTIME_DIR not set, falling back to .
> using socket ./wayland-0
> weston: nvfx_state_fb.c:42: nvfx_framebuffer_validate: Assertion 
> `util_format_get_blocksize(fb->cbufs[0]->format) == 
> util_format_get_blocksize(fb->zsbuf->format)' failed.
> Aborted

Hi Bill,

could you try commenting out the line
from compositor-x11.c?

I would very much like to know if that helps. If it gets Weston running
(all clients might still fail), you could try removing it from
everywhere in the weston repo.

Whether this helps or not, it's all about bugs in the nvfx driver
or the Nouveau gallium bits.

Weston does not use z-buffer for anything, but some clients might.


More information about the wayland-devel mailing list